Ask / Submit
22

Xperia X is in Mode "Prefer 4G" after reboot

Tracked by Jolla (In release)

asked 2017-10-12 18:22:53 +0200

Oleg gravatar image

updated 2017-10-18 16:26:24 +0200

emva gravatar image

Network cellular mode of my Xperia_X F5121 is "Prefer 4G" after each reboot. IMHO, it's not OK.

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted
21

answered 2017-10-13 08:17:11 +0200

deprecated gravatar image

The problem is that /var/lib/ofono is not writable. I wrote up a fix for this on TMO:

devel-su
systemctl stop ofono.service
cd /var/lib
mv ofono ofono.backup
mkdir ofono
chown radio:radio ofono
systemctl start ofono.service

After you do this, your settings with APNs and mobile data will stick following reboots.

edit flag offensive delete publish link more

Comments

7

/var/lib/ofono had the owner root:root and thus was empty. A chown radio:radio /var/lib/ofono systemctl restart ofono.service should suffice (worked for me), no need to backup an empty folder.

ghling ( 2017-10-13 09:41:35 +0200 )edit
1

@deprecated i tried it and it works!

another problem i have is that 2G/3G/4G doesnt work with WIFI off. It switches between enable/diabled constantly when looking at it in settings mobile data.

XFish ( 2017-10-13 10:37:44 +0200 )edit
1

@deprecated, it works! many thanks! :-)

Oleg ( 2017-10-13 11:11:04 +0200 )edit

@XFish make sure your APN settings are correct for your provider/carrier.

deprecated ( 2017-10-13 18:09:59 +0200 )edit

@XFish also please mark the question as answered if this helped you. Thanks!

deprecated ( 2017-10-13 20:37:36 +0200 )edit
Login/Signup to Answer

Question tools

Follow
5 followers

Stats

Asked: 2017-10-12 18:22:53 +0200

Seen: 671 times

Last updated: Oct 13