Ask / Submit
81

[Xperia X] Speakerphone volume too low

asked 2017-10-13 03:18:37 +0300

MartinK gravatar image

updated 2017-11-27 14:14:58 +0300

jiit gravatar image

The maximum speakerphone volume during a call seems to be much lower than on the Jolla C or the original Jolla phone.

I don't think this is a hardware limitation as sound output (system sound/music playback) can be much louder than the maximum volume in speakerphone mode. So seems like a separate speakerphone/telephony speaker output limitation.

Steps to reproduce

  1. call someone
  2. enable speakerphone mode (click the speaker icon)
  3. set volume to maximum using the volume keys
  4. compare maximum volume with Jolla C/Jolla 1

Actual result

Xperia X maximum volume in speakerphone mode is much lower than for Jolla C/Jolla 1.

Expected result

Xperia X maximum volume in speakerphone mode is comparable to Jolla C/Jolla 1.

Additional information

Overall microphone quality seem to be much better than on Jolla C as the other side can hear me just fine even from a distance, compared to Jolla C where I had to be quite close to the device in speakerphone mode otherwise the other side would not hear me very good. But looks like in exchange for that there is some echo heard by the other side on Xperia X - is that possibly the reson for the low maximum volume ? Eq. echo cancellation in speakerphone mode not working properly yet ?

edit retag flag offensive close delete

Comments

4

In my Xperia X if I enable "speaker mode" during a call it seems it doesn't work at all. I'm continuing to hear sound in "normal mode".

Luca ( 2017-10-17 15:29:04 +0300 )edit

@Luca I think it works. Only it's too low.

NikosAlexandris ( 2017-10-18 17:08:44 +0300 )edit
2

The first time I used it, I put volume to maximum, and immediately the person on the other end of the line mentioned an echo, so I suspect you're right that they've limited volume because the echo cancellation isn't quite there.

jb ( 2017-10-29 13:23:46 +0300 )edit
3

I think only one (of the two) speakers is activated during "hands-free" operation.

Mine is also extremely quiet

rfa ( 2017-10-31 22:57:57 +0300 )edit
3

It seems it affects several people. And, without it, making phone calls is practically not feasible.

NikosAlexandris ( 2017-11-02 09:59:03 +0300 )edit

5 Answers

Sort by » oldest newest most voted
1

answered 2017-11-16 17:18:49 +0300

lakutalo gravatar image

Find some cool approaches here:

https://together.jolla.com/question/68113/louder-than-100-volume/?answer=74840#post-id-74840

https://together.jolla.com/question/82958/audio-control-in-sailfish-setting-volume-via-cmd-line/?answer=88072#post-id-88072

edit flag offensive delete publish link more
1

answered 2018-02-21 13:05:07 +0300

zepher gravatar image

Previously echo correction was not enabled so I think this setting was deliberate to prevent echo/feedback. Hopefulky it's be fixed soon, speakerphone is not much use at the moment because of the low volune.

edit flag offensive delete publish link more
1

answered 2018-03-06 08:24:52 +0300

Direc gravatar image

I'm running 2.1.4.14 (2.1.4.13 most likely works, too) and just today noticed that the speakerphone now works as expected. Could someone confirm this?

(I had tried this before, but the file was overwritten by a system update. It should not affect me, but I thought I should mention it here anyway.)

edit flag offensive delete publish link more

Comments

2

The volume levels of Xperia X have not been touched but echo cancellation was added to the audio path in 2.1.4. This should have a positive effect.

jovirkku ( 2018-03-06 10:00:18 +0300 )edit

Well, all I can tell is that for me it works now... I have tried other things, too, that's why I asked for other users to test it. It seems that the speaker mode (whatever it is that happens in pulseaudio and hardware level) now works...for me, that is.

Direc ( 2018-03-06 11:18:14 +0300 )edit

Hi.

I recall testing it again after updating to 2.1.4.13 and still not working. All the files in the folder have modification date Dec 21 00:55

I had to re-edit the file again to make it work... so I don't know if they fixed it or not....but if it works for you, I guess it's ok. :-)

Regards.

Pasko ( 2018-03-06 14:01:50 +0300 )edit

Thanks for your test, @Pasko!

My analog-output-speaker.conf file size is 4521 and its timestamp is 2012-12-21 01:55 -- in GMT+2 time zone (Finland). The [Element Speaker] section is identical to [Element Desktop Speaker], that is, they both have switch = mute (no changes made) and my speaker toggle Just Works... How strange.

Will reboot and test, let's keep Bluetooth off this time...

Direc ( 2018-03-06 19:17:53 +0300 )edit

2.1.4.14 update fixed the loudspeaker volume for me too, it is now useable.

vbregier ( 2018-03-10 13:38:51 +0300 )edit
0

answered 2017-11-27 13:49:17 +0300

TomC gravatar image

Not an actual answer to the problem, but probably a related issue:

https://together.jolla.com/question/174732/xperia-x-speaker-phone-audio-feedback/

edit flag offensive delete publish link more
0

answered 2018-02-15 11:55:08 +0300

evo3de gravatar image

Xperia X: Same here, Call via BT coupled Carradio... almost the speaking volume is to low / ringing volume is ok

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
17 followers

Stats

Asked: 2017-10-13 03:18:37 +0300

Seen: 2,096 times

Last updated: Mar 06 '18