We have moved to a new Sailfish OS Forum. Please start new discussions there.
9

[Whatsapp][bug] Status always online [released]

asked 2017-10-16 02:23:14 +0200

carmeloferso gravatar image

updated 2018-02-16 21:54:52 +0200

Hi, I'm new user of Sailfish X and I noticed (well, people told me) even if I closed Whatsapp trough the app drawer, my status is almost always online. Sometimes after a minute gets offline and sometimes after 10 minutes. Someone from Maemo.org told me that I have to swicht off the option "Start Android support on bootup", but it didn't solve.

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by carmeloferso
close date 2019-07-23 00:08:44.975853

Comments

1

Hi. I have same problem. Always i close the whatsapp says offline but no show more message :(

Rafaelvlmendes ( 2017-10-16 07:50:34 +0200 )edit
5

Personally I'm not sure it's a bad thing -- it prevents people from tracking my online status (see https://nakedsecurity.sophos.com/2015/02/17/whatsapp-spy-tool-lets-anyone-track-when-youre-online/).

Federico ( 2017-10-16 21:33:30 +0200 )edit
2

Please remember: Whatsapp is a Facebook thing.

objectifnul ( 2017-11-02 20:01:11 +0200 )edit
6

I'm a big fan of this problem! Please dont fix it ;-) People cant track if im online or not, it's really nice! :D

lumen ( 2017-11-02 22:25:22 +0200 )edit
1

Maybe it helps if yo use the kill android button from openrepos...

BonoNL ( 2017-12-10 21:38:57 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2017-12-08 16:59:37 +0200

SaimenSays gravatar image

It is good to be visible online everytime. It is a kind of privacy not showing everybody when I am doing something with the phone...

edit flag offensive delete publish link more
0

answered 2017-10-16 12:59:57 +0200

Sakke gravatar image

I'm not a user of Sailfish X, but I've had similar issues with WhatsApp's Online status thing on my JP1. Firstly, are you sure that all WhatsApp processes are completely killed when this issue occurs. There could be a background process. Make sure that you don't have setting "Allow application background services to start on bootup" on since if this is on, there will be a background process. This setting can be found on Settings > Apps > WhatsApp

On the whole, WhatsApp Online thing isn't going to work properly because the issue lies on aliendalvik (Android Support) and the way it is functioning with Sailfish OS. There are quite a few issues with Android apps's background processes not starting up properly on Sailfish OS. I think it's due to Sailfish multitasking; either the app is killed or running.

edit flag offensive delete publish link more

Comments

If I disable from background process, I won't receive any message, so that is not a solution for me. Anyway, I reported here so maybe someone could help to solve this, or maybe Jolla does

carmeloferso ( 2017-10-16 17:12:13 +0200 )edit
1

I think the only solution is to accept that if you want to receive WhatsApp messages/notifications, you'll be "Online" all the time or otherwise you won't receive messages at all. I've always kept WhatsApp open in the app view, and closed it if I hadn't needed it (for example at night).

This WhatsApp behavior has been reported many times before, and if I've understood correctly, there are no intends of solving this. It has actually been there from the very beginning of Sailfish OS.

Sakke ( 2017-10-16 18:22:32 +0200 )edit
3

Well... I think that I can live with it.

carmeloferso ( 2017-10-17 02:37:33 +0200 )edit

Question tools

Follow
8 followers

Stats

Asked: 2017-10-16 02:23:14 +0200

Seen: 2,684 times

Last updated: Feb 16 '18