Ask / Submit
11

Xperia X WLAN sharing not working [answered]

asked 2017-10-16 11:19:17 +0200

Direc gravatar image

updated 2017-10-16 11:19:57 +0200

Hi 'yall!

I just installed SFOSX a few days ago, and it seems that internet connection sharing using WLAN doesn't work. I can click the icon, WLAN symbol flashes on briefly, then hotspot symbol keeps lit, but I can't find any networks.

Can anyone confirm or test this please?

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Direc
close date 2017-10-16 12:15:09.164686

Comments

4

I've written a little script that you can put in /home/nemo to toggle wlan-sharing ON/OFF.

#!/bin/bash

if [ "$EUID" -ne 0 ]
  then echo "Please run as root (type devel-su first)"
  exit 1
fi

if [[ $1 == "off" ]]; then
  echo "Best way to turn off hotspot at the moment is restarting your device..."
  exit 0
elif [[ $1 == "on" ]]; then
  echo "Switch Tethering ON.."
  echo 2 > /sys/module/bcmdhd/parameters/op_mode
  sleep 1
  echo "Now restart WLAN from UI (\"Settings > WLAN\") and enable hotspot (\"Settings > Internet sharing\")"
  read -p "Done with the instruction above? Then press [Enter] to continue..."
  ip link set dev wlan0 master tether
  sleep 1
  echo "Enjoy tethering on your Xperia X!;)"
  exit 0
else
  echo "USAGE: $0 <on><off>"
  exit 1
fi
joschobart ( 2017-10-19 00:56:13 +0200 )edit

USB Tethering works well without any issues (on xperia X too) see here - https://together.jolla.com/question/3798/usb-tethering/

SymbianRefugee ( 2017-10-27 06:27:26 +0200 )edit

excuse me all, How can I do to copy this script in my Xperia? In a .txt file? and what shall I name this file? Thanks from a very beginner.

luca ( 2017-12-19 20:32:51 +0200 )edit

This method doesn't work with Sony Xperia XA2, it doesn't have /sys/module/bcmdhd. It has something under /sys/module/wlan, but no op_mode there.

shmerl ( 2018-12-17 02:19:36 +0200 )edit

2 Answers

Sort by » oldest newest most voted
7

answered 2017-10-16 11:22:30 +0200

tmy gravatar image

updated 2017-10-16 11:22:51 +0200

It's listed in release notes as not yet supported feature: https://together.jolla.com/question/168541/release-notes-213-kymijoki-for-sony-xperia-x/

edit flag offensive delete publish link more

Comments

Thanks. I had somehow missed that page.

Direc ( 2017-10-16 12:15:54 +0200 )edit
3

answered 2017-10-21 20:54:44 +0200

TomC gravatar image

updated 2017-10-21 21:13:51 +0200

There seems to be a workaround for this issue:

http://jolla.zendesk.com/hc/en-us/articles/115013777068

edit flag offensive delete publish link more

Comments

Doesn't work for me; my laptops 'see' the Xperia's network but wil keep trying to connect andget a network adress, but they never get it ...

mrtrm ( 2017-10-21 23:36:45 +0200 )edit

Question tools

Follow
8 followers

Stats

Asked: 2017-10-16 11:19:17 +0200

Seen: 1,265 times

Last updated: Oct 21 '17