Ask / Submit
2

Creation of MS Exchange account stuck

asked 2017-10-17 11:15:06 +0300

fifr gravatar image

updated 2017-10-17 11:17:58 +0300

I have trouble with calendar synchronization via an MS Exchange account (as in this bug). So I tried to enable debugging messages in ~/.config/eas-sailfish.conf and to recreate the account. Now I cannot even create a new account, the process stops with a busy screen showing "Konto wird erstellt..." ("Account is created" in German) and the journal shows the messages below. Note that this happened before I enabled debugging, too, I always needed several tries until the account is created.

Oct 17 09:59:11 Sailfish estart[3495]: [D] unknown:0 - account.cpp: 626 account_store_cb Saved accunt ID: 49
Oct 17 09:59:11 Sailfish estart[3495]: [W] unknown:0 - writeProfileFile() called, forcing disk write: "/home/nemo/.cache/msyncd/sync/sailfisheas.Email-49.xml"
Oct 17 09:59:11 Sailfish estart[3495]: [W] unknown:0 - writeProfileFile() called, forcing disk write: "/home/nemo/.cache/msyncd/sync/sailfisheas.Calendars-49.xml"
Oct 17 09:59:11 Sailfish estart[3495]: [W] unknown:0 - writeProfileFile() called, forcing disk write: "/home/nemo/.cache/msyncd/sync/sailfisheas.Contacts-49.xml"
Oct 17 09:59:11 Sailfish estart[3495]: [D] unknown:0 - account.cpp: 626 account_store_cb Saved accunt ID: 49
Oct 17 09:59:11 Sailfish estart[3495]: [D] unknown:0 - account.cpp: 626 account_store_cb Saved accunt ID: 49
Oct 17 09:59:11 Sailfish estart[3495]: [D] unknown:0 - account.cpp: 626 account_store_cb Saved accunt ID: 49
Oct 17 09:59:11 Sailfish estart[3495]: [D] onCheckCredentialsDone:227 - [jsa-eas] Credentials OK!
Oct 17 09:59:11 Sailfish estart[3495]: [W] unknown:38 - file:///usr/lib/qt5/qml/Sailfish/Silica/private/Util.js:38: TypeError: Cannot read property 'parent' of null
Oct 17 09:59:11 Sailfish estart[3495]: [D] doPush:131 - Warning: cannot push while transition is in progress
edit retag flag offensive close delete

Comments

Same issue here...

xneo ( 2017-10-17 11:42:30 +0300 )edit

Same here :(

orol ( 2017-10-17 16:13:47 +0300 )edit

Same here :(

ehakkarainen ( 2017-10-30 18:57:54 +0300 )edit

5 Answers

Sort by » oldest newest most voted
1

answered 2017-10-17 22:09:03 +0300

jumPM gravatar image

I had the same problem with ActiveSync connection to Kerio Connect on Sailfish X. After server-side exclusion some custom email folders the account creation succeeded. Then I reactivate the excluded folders and they get synced with my Sony Sailfish X.

What I noticed is that private and public email folders in the list of folders are messed up. On my Jolla 1 the mail folders are sorted correctly.

edit flag offensive delete publish link more
0

answered 2017-10-17 11:44:42 +0300

xneo gravatar image

I had success with... opening terminal ... start settings with "jolla-setting" ... create account ... when it gets stuck you should kill "jolla-settings" in terminal... then you can go to settings and activate account...

This is the dirty way and I got man problems with my contacts list, so I am wating for another solution.

edit flag offensive delete publish link more

Comments

This worked for me once, the second time I tried (after removing the account again) the account creation got stuck again

fifr ( 2017-10-17 12:28:33 +0300 )edit

I had success with another dirty method... When you get stuck in the creation let the app run more than 10 Minuten and then restart the phone. Then the account should be created and deactivated. By activating the exchange account should work.

I hope they will some improvements to further Exchange Active Sync versions...

xneo ( 2017-10-17 14:28:41 +0300 )edit
0

answered 2017-10-18 07:44:53 +0300

GD gravatar image

There seams to be an issue with provisioning. Had same issue, unset Provisioning it's the last option. Then the account will be created so long as Provisioning is not a requirement for the account.

edit flag offensive delete publish link more
0

answered 2017-10-18 08:49:41 +0300

lancelin2k7 gravatar image

Create the account. Untick provisioning. The account will be created but not sync. Then go back in to settings and reselect provisioning and it should sync ok. Mine has been doing this for months. To be taken seriously, sailfish really needs a decent email app. Lets face it the current one is crap.

edit flag offensive delete publish link more

Comments

I tried this several times, but the calendar entries still do not sync

fifr ( 2017-10-20 10:16:20 +0300 )edit

For me it is helped, calendar and people sync two-ways.

orol ( 2017-10-20 20:41:05 +0300 )edit
0

answered 2017-10-24 19:40:38 +0300

elkiaer gravatar image

updated 2017-10-24 19:48:12 +0300

I have the same issue with the Exchange account. I do also have some issue with the google account, here it is not possible for me to sync the contacts.

But –

Using the Yahoo account I can sync both the calendar and the contact. I have added this account now and maybe also in the future :-) I guess that Jolla is working hard on solving the issue with the Exchange.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2017-10-17 11:15:06 +0300

Seen: 401 times

Last updated: Oct 24 '17