Ask / Submit
41

Bluetooth audiostream is choppy when WLAN is on

Tracked by Jolla

asked 2017-10-17 22:19:32 +0200

michfu gravatar image

updated 2018-09-19 11:44:53 +0200

When listening to music in my car (Xperia connected via bluetooth to Renault Radiosat) the audiostream is interrupted every approximatly 5sec when WLAN is on. As soon as I turn off WLAN, the stream is ok.

UPDATE: still present on 2.1.4.14 and 2.2.0.29

EDIT2: still present on 2.2.1.18

EDIT3: related issue: https://together.jolla.com/question/181324/bt-audio-stuttering-when-wlan-enabled/

edit retag flag offensive close delete

Comments

2

I got the same but choppiness diappears after 10 or so seconds on mine.

XFish ( 2017-10-18 04:37:52 +0200 )edit
1

Yeah the line discipline isn't particularly great yet, the wifi and the bt are run off the same chip

r0kk3rz ( 2017-10-18 10:56:29 +0200 )edit
1

Hi @r0kk3rz , a related question: Did you recognize a difference in sound quality of the bt audio stream after the switch from bluez4 to bluez5?

michfu ( 2017-10-18 11:01:06 +0200 )edit
1

Same problem for me but I didn't try with the wlan off. The audio stream does have hiccups while listening to music but not during a phone call. That's strange.

Toniob ( 2017-10-18 11:33:38 +0200 )edit
2

Strange... I can't get audio out via Bluetooth at all... Will test this after reboot.

Direc ( 2017-10-18 14:31:07 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-11-10 14:31:57 +0200

kumottolo gravatar image

hello,

i had the same issue with Xperia X and SF 3.0.

I realised it was due to the Bluetooth settings that kept searching for devices even after it paired with the bluetooth speaker. i fixed it by, while in the bluetooth setting page, sliding down and selecting "stop searching". it immediately solved the audio stuttering problem (enabling/disabling WLan does not affect it in my case).

best

edit flag offensive delete publish link more

Comments

Hey, I also tested this, and I found that sometimes audio streaming stuttering but it's just only few "peaks" per 5 minutes or something. I also noticed that if I navigating in sailfish and do some basic things, there is more often this audio choppiness.

And of course both cases I have enabled wlan and also connected my home network.

So afterall this is issue even when using just bluetooth speakers with xperia x

Jk ( 2018-11-10 20:04:57 +0200 )edit

hello,

after further testing I have been experiencing exactly the same as you (stuttering every now and then, especially if navigating). It is not too bad, but annoying at times.

best

kumottolo ( 2018-11-11 13:21:05 +0200 )edit
0

answered 2019-02-17 14:41:36 +0200

mase gravatar image

Disabling Wifi made it somewhat better. But the choppiness every few minutes is very annoying. This makes no fun listening to music. Even annoying when listening to speech. I hope, Jolla will fix this very soon. Is there a better way to log? I want to find out, what happens when stuttering. journalctl -f only tells me, that some audio frames were skipped.

edit flag offensive delete publish link more

Comments

The stuttering sound when wifi is deactivated appears exactly every 3 minutes. Neither dbus-monitor nor journalctl -f shows something in this moment. I tried high-priority = yes and nice-level = -1 in /etc/pulse/daemon.conf. But this had no effect. How can I figure out, what happens every 3 mins?

mase ( 2019-02-19 08:49:30 +0200 )edit

It might be a bug in the Android binary blobs. As Bluetooth and WLAN 2.4GHz use the same frequencies, they must take turns, stop and go, and the (lack of) co-operation is what causes the stutter. There is little that can be done on the Sailfish end of the court. Let's hope the next release uses newer firmware blobs...

Direc ( 2019-02-20 23:30:51 +0200 )edit

Maybe, but Wifi is deactivated. So it should not affect bluetooth.

mase ( 2019-02-21 20:09:27 +0200 )edit
Login/Signup to Answer

Question tools

Follow
14 followers

Stats

Asked: 2017-10-17 22:19:32 +0200

Seen: 893 times

Last updated: Feb 17