Ask / Submit
7

Xperia X doesn't remember stored wlan

asked 2017-10-18 21:35:51 +0200

silta gravatar image

updated 2017-11-18 18:28:47 +0200

When I go to settings > wlan and switch on wlan it connects with stored wlan immediatley if reachable.

But when I try to switch wlan on via shortcut in events view, the phone starts searching for available wlan and let me choose from a list. So the shortcut is no longer a shortcut.

Has someone discovered the same behavior or has a solution?

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted
6

answered 2017-10-18 22:54:57 +0200

vision gravatar image

updated 2017-10-18 22:55:19 +0200

Yes, it is searching the available WLANs again but you don't have to choose explicitely the already stored WLAN after activating via shortcut. It is connecting automatically and you just can swipe away the events view (or just tap on the screen outside the WLAN search field.

edit flag offensive delete publish link more

Comments

Thanks for the hint, that makes the shortcut a little bit shorter ;-)

But nevertheless it isn't the normal behavior.

silta ( 2017-10-19 08:08:26 +0200 )edit

Agree.... but is not related to Xperia X. Same behaviour is on JollaC as well.

vision ( 2017-10-19 10:47:08 +0200 )edit

Okay, but in my Jolla1 it works perfect from begin. So I think it should be fixed for other official hardware. Would be interesting to know how it works on Aquafish and Tablet.

EDIT 18-11-2017: Since I´ve updated my JP1 to SFOS 2.1.3.5. the same behavior here, so it seems not limited to XperiaX only.

silta ( 2017-10-19 11:18:35 +0200 )edit
1

Is it a bug or is that what the developers wanted? I don't understand the meaning of it, why searching again? Toggle on/off would be enough, as it is now it is annoying.

micha77 ( 2017-11-18 20:52:41 +0200 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2017-10-18 21:35:51 +0200

Seen: 291 times

Last updated: Nov 18 '17