Ask / Submit
9

small bug: notification LED blinking also in your pocket [answered]

asked 2014-01-19 15:48:40 +0300

axaq gravatar image

updated 2014-09-18 21:06:04 +0300

rainisto gravatar image

The notification LED is still blinking if you are covering the proximity sensor. So it should also happen inside your pocket or face down.

Maybe the power saving effect is minimal but I was wondering about it.

Fixing this would also help with Bug: Don't activate LED notification during a phone call!.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by axaq
close date 2014-10-03 20:53:16.516060

Comments

I've heard from sevaral others that the proximity sensor isn't sensitive enough, like triggering actions with the chin.

Tanghus ( 2014-01-19 15:56:46 +0300 )edit

2 Answers

Sort by » oldest newest most voted
6

answered 2014-01-19 19:22:39 +0300

blubdibub gravatar image

updated 2014-01-19 19:25:50 +0300

The proximity sensor is an infrared led + receiver. So if there is any power saving this is nearly zero. It might even consume more power to check everytime whether the phone is in an pocket or not, than to just blink the led. On the one hand you have the notification led. On the other hand an ir-led, an ir-receiver and the logic requiered to analyse it.

Apart from possibly saving power I don't see any andvantage of this feature. And because as I stated the power saving argument is more than questionable I dont think this needs to be implemented.

+ Regarding the other question you linked: This could be easily done by just deactivating the notification led during calls. Maybe Jolla could use the proximity sensor here to turn off the screen + the notification led. But this check would only be required during calls. Not always.

edit flag offensive delete publish link more
5

answered 2014-09-18 08:39:13 +0300

spiiroin gravatar image

We did consider turning off the led if proximity sensor is covered. But then it would be quite possible to miss the indication if the device sitting on a table gets the proximity sensor obstructed by papers, monitors, cables, etc. Extra power consumption from blinking in pocket was deemed lesser of the two evils.

@simo: No settings ui for this, but there is "master toggle" that will disable/enable most of the led patterns from command line:

  • mcetool --disable-led
  • mcetool --enable-led

@Tanghus: Initially the proximity blanking during calls used raw proximity state. That combined with relatively long time it takes to power up/down the display & touch meant that short uncovering of the proximity sensor could lead in to touch events from ear/chin getting through. Since then this has been changed so that: covering the sensor -> blank asap, uncovering the sensor -> wait a while to see if it stays uncovered before unblanking. Also if the display is powered up while it is touched, the input stays blocked until touch end is detected. While it is still possible to get unwanted touch events, it is better than what it used to be.

edit flag offensive delete publish link more

Question tools

Follow
2 followers

Stats

Asked: 2014-01-19 15:48:40 +0300

Seen: 506 times

Last updated: Sep 18 '14