Ask / Submit
6

[SailfishX] Camera won't save to SD card [answered]

asked 2017-10-30 23:32:47 +0300

sunburnedpenguin gravatar image

updated 2017-11-13 12:45:19 +0300

JoHe gravatar image

After formatting my 128 GB SD card to F2FS, the option to save pictures/videos to the SD card results in "selected storage not available". My symlink to store gPodder podcasts to the SD card works fine. System Settings-->Storage shows the SD card mounted. Does the System Settings-->Apps-->Camera-->Storage setting to store items on the SD card only work if it's FAT32 (which obviously won't work for a larger card)? Even here, it shows the remaining space on the SD card but returns the "selected storage not available" error message.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by JoHe
close date 2017-11-13 12:45:32.028539

Comments

Similar (albeit not the same) problem here, I was looking forward to using f2fs in action, but, alas, it seems to be making trouble when SFX writes to it: When I select it as storage for the camera, the device will reboot after about a minute of not responding, and starting the camera after that will do the same... However, I can access all data that is already on the card... (e.g. play the music and stuff on it)

eriXD ( 2017-10-31 00:18:49 +0300 )edit

Have you yet tried replacing the main storage Pictures folder and subdirs with a symlink?

sunburnedpenguin ( 2017-10-31 00:45:01 +0300 )edit
2

I have a 128GB ext4 formatted card, and have no problem using it as storage for camera.

Kim ( 2017-10-31 10:08:55 +0300 )edit

Thanks for the info, Kim. Glad it works with ext4, but I'd prefer to use a file system more optimised for flash memory (F2FS, UDF, BTRFS, etc.)

sunburnedpenguin ( 2017-11-01 17:59:34 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2017-11-10 17:55:59 +0300

sunburnedpenguin gravatar image

Thanks to @wvh for the solution in this thread: https://together.jolla.com/question/169040/sailfishx-microsd-card-not-detected/?answer=172583#post-id-172583

I suppose I forgot to re-own the SD card mount point as nemo! After installing f2fs-tools via Warehouse, formatting the SD card with F2FS, chowning the mount point, and then removing f2fs-tools (for the heck of it), I was able to set the card as storage for the camera without any issues.

edit flag offensive delete publish link more

Comments

How about a wiki for new sailors on how you achieved this as your posts (any any other potential guide to achieve the same thing) are vague or non-existent.

jimjamz ( 2017-11-19 15:22:19 +0300 )edit

Question tools

Follow
3 followers

Stats

Asked: 2017-10-30 23:32:47 +0300

Seen: 365 times

Last updated: Nov 10 '17