Ask / Submit
13

mms not working on sailfish x

Tracked by Jolla

asked 2017-11-09 03:24:18 +0300

erdinch gravatar image

updated 2018-03-24 15:23:03 +0300

eson gravatar image

hello,

trying to get mms working on metro pcs network with sailfish x. can anyone help me out? as soon as u insert the sim , talk text and internet work, but sending and receiving images does not work.

edit retag flag offensive close delete

Comments

I suggest you change the topic since this is an operator bug and nothing to do with SFOS or Xperia...

I am in Elisa 4G network and everything works OK.

juiceme ( 2017-11-16 08:19:04 +0300 )edit

I am also in Elisa 4G network and everything dont work. 3G everything works OK.

Gouneesz ( 2017-12-27 12:14:44 +0300 )edit

My settings are: Elisa FIMMS. (APN) mms. Protokolla IP. Todennustapa Ei. 213.161.41.57. Portti 80. http://mms.elisa.fi. Viestin suurin koko Keskikokoinen.

Gouneesz ( 2017-12-28 23:26:11 +0300 )edit

Definitely provider specific. Swisscom works just fine, both sending and receiving MMS.

Venty ( 2018-03-07 17:01:22 +0300 )edit

Sometimes the image size is not allowed by operator. Have you tried small or medium rather than original and large size image setting? (Since xperiax images are huge compared to those from c or 1 phones)

ljo ( 2018-03-24 16:41:21 +0300 )edit

15 Answers

Sort by » oldest newest most voted
2

answered 2017-11-11 11:38:36 +0300

eson gravatar image

updated 2018-03-24 15:28:20 +0300

Same problem on Hallon (tre) network in Sweden. Receiving/Sending MMS don't work (Problem with downloading/sending message). All settings seem to be okay.

Update: This is still a problem on SFOS 2.1.4.14, and it's NOT provider specific. The same SIM card with exactly the same konfiguration is working just fine on my Jolla Phone and Jolla C. The problem is definitely in Sailfish X.

edit flag offensive delete publish link more
1

answered 2017-11-15 21:47:22 +0300

DNG gravatar image

Same problem for me on Telenor in Sweden. Receiving/sending MMS does not work. Settings seems ok (same as fully working Jolla1).

edit flag offensive delete publish link more

Comments

1

I had this problem with Telenor SE. I randomly started changing settings, and eventually it started working. I think I ended up with the same settings I started with. (Perhaps changing some setting back and forth fixed it?)

Anyway, here are my current settings: - Roaming: do not allow (when it started working, I had set this to allow) - Data name: internet.telenor.se - Data protocol: both (IP when it started working) - Data auth: none - MMS name: services.telenor.se (briefly set this to internet.telenor.se, data stopped working and changed back) - MMS protocol: IP - MMS auth: none - MMS proxy: 172.030.253.241 (tried clearing this, did not work) - MMS proxy port: 8799 (tried clearing and various ports, did not work) - MMS URL: http://mms - Message size: Very large (set to large when it started working)

TW ( 2017-12-14 19:30:34 +0300 )edit

Thank you for advice. Tried what you suggested, but does not work for me. Strange.

DNG ( 2017-12-28 21:52:40 +0300 )edit

Since 2.1.4.14 it now works fine with Telenor 😊

DNG ( 2018-03-31 00:47:00 +0300 )edit
1

answered 2017-11-16 11:43:21 +0300

lutinotmalin gravatar image

I had the same problem but now it's fixed. Try to downgrade the MMS quality.

It didn't work for me when it was set to 'Very big (1mb)'. I tried the second one, 'Big (600 kb)' and then everything worked perfectly fine. I can now receive and send MMS without any problems.

In France on Sosh (by Orange).

edit flag offensive delete publish link more

Comments

where do you set it up please?

omichalek ( 2017-11-16 11:45:47 +0300 )edit

Settings > Applications > Messages

;)

lutinotmalin ( 2017-11-16 11:51:36 +0300 )edit
1

I see, setting it to small hasn't helped me

omichalek ( 2017-11-16 12:08:25 +0300 )edit

It worked here (Orange, France). Thanks for the workaround, but nevertheless, this is a bug...

lunatix ( 2017-11-16 17:22:55 +0300 )edit
1

answered 2018-03-07 14:01:28 +0300

Raymaen gravatar image

updated 2018-03-07 16:59:50 +0300

Same problem on T-Mobile Germany. After update to [2.1.4.14] its not working anymore! In 2.1.3.7 everything was O.K. I am using Sailfish X.

edit: just now i switched to flightmode and back. Then i tried to download the mms again and after i got connection back it woked. * hmpf... * So this looks like an issue with the connectivity to the networks, that is stil a mess.

edit flag offensive delete publish link more

Comments

And your settings are correct?

SValmont ( 2018-03-07 16:23:11 +0300 )edit
1

what do you mean by settings? it worked on 2.1.3.7 and after the update it did not work anymore.

Raymaen ( 2018-03-07 16:54:06 +0300 )edit

There are specific settings that were defaultly wrong as outlined above. You need to have MMS specific settings based on your network provider. I'm guessing the upgrade changed these settings to something incorrect or blanked them. Double check the MMS settings with those outlined by your provider. Usually these can be found on your provider's website.

SValmont ( 2018-03-07 18:35:04 +0300 )edit
1

answered 2018-03-07 16:24:00 +0300

Cube gravatar image

update to [2.1.4.14] on Sailfish X ... no pb to send a MMS with Orange France. Test done with my colleague.

edit flag offensive delete publish link more
0

answered 2017-11-11 03:32:15 +0300

rohanarora gravatar image

Ran into a similar issue on Metro PCS' parent TMobile. Fixed it by setting the MMS settings in Settings -> Cellular -> MMS access point. Hope this Android Central article has the right settings: https://www.androidcentral.com/change-apn-metropcs

edit flag offensive delete publish link more

Comments

heres where i get confused. after i click mms access point, what is the proxy port, proxy address and mms message center address. also, protocol and authentication . i dont see it from the webpage you provided. could u help me out?

erdinch ( 2017-11-11 03:50:46 +0300 )edit

MMS message center address (aka MMSC): http:// metropcs.mmsmvno.com/mms/wapenc Leave the proxy and port settings blank.

rohanarora ( 2017-11-11 03:56:41 +0300 )edit

rohan this didnt work . i cant receive mms. in celular do i have to correct any other apn settings?

erdinch ( 2017-11-11 05:33:50 +0300 )edit

Bizarre. I'd reach out to MetroPCS to ensure that the settings are good.

rohanarora ( 2017-11-11 15:43:23 +0300 )edit
0

answered 2017-11-15 13:21:27 +0300

sailus gravatar image

Same here, in Finland on Elisa network.

edit flag offensive delete publish link more
0

answered 2017-11-16 10:45:20 +0300

lunatix gravatar image

Same here with Orange in France.

edit flag offensive delete publish link more
0

answered 2017-11-16 11:22:53 +0300

omichalek gravatar image

updated 2017-11-16 11:43:32 +0300

same here, t-mobile cz

edit: What happens is that an image is uploaded several times, but it reports "problem with sending message". My settings are correct according to this: https://www.t-mobile.cz/podpora/nastaveni-telefonu/nastaveni-telefonu-pro-mms-wap-a-e-mail/nastaveni-mms

edit flag offensive delete publish link more
0

answered 2017-11-17 11:31:29 +0300

phklrz gravatar image

At first, it didn't work for me with SFR France. However, changing the APN for MMS from "mmssfr" to "sl2sfr" and changing the setting for size from "very big" to "big" made it work for me. So, it seems to me that it is an operator issue.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2017-11-09 03:24:18 +0300

Seen: 1,717 times

Last updated: Apr 12