Ask / Submit
15

mms not working on sailfish x

Tracked by Jolla

asked 2017-11-09 03:24:18 +0300

erdinch gravatar image

updated 2018-06-01 06:49:43 +0300

eson gravatar image

hello,

trying to get mms working on metro pcs network with sailfish x. can anyone help me out? as soon as u insert the sim , talk text and internet work, but sending and receiving images does not work.

edit retag flag offensive close delete

Comments

I suggest you change the topic since this is an operator bug and nothing to do with SFOS or Xperia...

I am in Elisa 4G network and everything works OK.

juiceme ( 2017-11-16 08:19:04 +0300 )edit

I am also in Elisa 4G network and everything dont work. 3G everything works OK.

Gouneesz ( 2017-12-27 12:14:44 +0300 )edit

My settings are: Elisa FIMMS. (APN) mms. Protokolla IP. Todennustapa Ei. 213.161.41.57. Portti 80. http://mms.elisa.fi. Viestin suurin koko Keskikokoinen.

Gouneesz ( 2017-12-28 23:26:11 +0300 )edit
1

Definitely provider specific. Swisscom works just fine, both sending and receiving MMS.

Venty ( 2018-03-07 17:01:22 +0300 )edit

Sometimes the image size is not allowed by operator. Have you tried small or medium rather than original and large size image setting? (Since xperiax images are huge compared to those from c or 1 phones)

ljo ( 2018-03-24 16:41:21 +0300 )edit

20 Answers

Sort by » oldest newest most voted
0

answered 2017-11-16 10:45:20 +0300

lunatix gravatar image

Same here with Orange in France.

edit flag offensive delete publish link more
0

answered 2017-11-16 11:22:53 +0300

omichalek gravatar image

updated 2017-11-16 11:43:32 +0300

same here, t-mobile cz

edit: What happens is that an image is uploaded several times, but it reports "problem with sending message". My settings are correct according to this: https://www.t-mobile.cz/podpora/nastaveni-telefonu/nastaveni-telefonu-pro-mms-wap-a-e-mail/nastaveni-mms

edit flag offensive delete publish link more
0

answered 2018-03-27 11:59:14 +0300

Gouneesz gravatar image

updated 2018-03-27 12:02:14 +0300

That was my fault. I had written incorrectly. Now works for mms messages. My service provider is Saunalahti (not Elisa) and there was no reason for that. My apologies.

edit flag offensive delete publish link more
0

answered 2018-03-28 11:02:45 +0300

Jolkas gravatar image

For me the opposite: since I use SailfishX mms is suddenly working (O2, Germany), don't know why (I don't use it very often).

edit flag offensive delete publish link more
0

answered 2018-03-28 16:18:10 +0300

I've also noticed that MMS does not work in wifi for me, but will work if I disconnect on use mobile data.

edit flag offensive delete publish link more

Comments

2

MMS can't work on WiFi as this is a mobile provider mobile network feature.

Filip K. ( 2018-03-31 12:20:28 +0300 )edit

I meant, if wifi is enabled at all.

SValmont ( 2018-09-19 18:37:23 +0300 )edit
0

answered 2018-03-30 21:45:19 +0300

Doesn't work on Cricket in the US or ATT. i HAVE SPENT DAYS TRYING TO GET THE SETTING STO WORK AND THEY DONT WORK

edit flag offensive delete publish link more
0

answered 2018-04-12 02:08:13 +0300

Oldmil gravatar image

updated 2018-04-12 02:10:16 +0300

I'm having quite a bit of trouble getting this to work with Cricket Wireless in the USA. Cricket's APN settings are as follows:

Name: Internet APN: ndo MMSC: http://mmsc.aiowireless.net MMS Proxy: proxy.aiowireless.net Multimedia Message Port: 80 APN protocol: IPv4 APN roaming protocol: IPv4 Turn APN on/off: ON Those settings I can configure.

MCC: 310 MNC: 150 APN type: default,mms,fota,hipri,supl These settings I can't find a place to configure

I've tried both IP and Dual as the protocols, both work well for SMS, internet browsing, and email. But pictures on MMS consistently fail to download. Occasionally they will download when the internet connection is turned off and then back on. But it stops working in short order after that.

I've tried both the very large and large settings in the apps -> messaging menu and when it works it seems to work on large.

edit flag offensive delete publish link more
0

answered 2018-09-18 18:25:38 +0300

updated 2018-09-19 18:38:52 +0300

Turning Airplane Mode on and off also helps with the problem if the APN settings are correct, but its still not working. Tired of the large delays in getting an MMS when it "gets" stuck. Spending too much time messing with this since the last update.

edit flag offensive delete publish link more
0

answered 2018-11-27 18:02:43 +0300

This thread's gone a bit quiet... figured I'd make sure it doesn't die out. Apologies as I can't seem to get hyperlinks working.

Just flashed Sailfish X free trial onto a brand new unlocked Xperia Xa2 with AT&T, everything works except MMS. I am IN LOVE with this OS, but I just can't sort this one issue out.

Tried the solutions proposed at https://talk.maemo.org/showthread.php?t=99925&highlight=mms&page=3 and https://www.reddit.com/r/sailfishos/comments/86tlmx/apn_setting_for_att_in_us/, disabled wifi and did airplane mode on/off several times.

Default APN settings in MMS Access Point on phone startup:

Connection Name: AT&T MMS Access Point Name: NXTGENPHONE Protocol: IP Authentication: None Proxy Address: 172.26.39.1 Proxy Port: 80 MMS Message Center Address: http://mmsc.mobile.att.net

Data Access Point default settings:

Connection Name: AT&T Internet APN: NXTGENPHONE Protocol: Dual Authentication: None

Adjusted the Protocol/Proxy Address/Name and APN (to phone, with proxy.mobile.att.net, per https://apn.gishan.net/en/apn/att), but nothing seems to work. Chaning the APN to "phone" and the proxy address managed to switch things from "waiting..." to "downloading...", but it still hung for ages and then led to an error message. Anyone out there with similar issues/maybe another solution?

edit flag offensive delete publish link more

Comments

When it hangs, I've restarted my phone and then restarted the MMS download. Sometimes that gets it to download instantly.

SValmont ( 2018-11-27 18:32:28 +0300 )edit

I've never used MMS, but I do know that there are some settings for MMS that may or may not help you. Navigate to Settings/Apps/Messages/MMS

Edz ( 2018-11-27 18:53:59 +0300 )edit

I do recommend that you get the MMS logger app from openrepos https://openrepos.net/content/slava/mms-logger

It has a way to submit the logs to Sailfish and they respond. I am also a AT&T user and it is hit or miss, fortunately most of my communication is on Signal so it is an issue that I can live with, which is why I did not spend too much time on this.

marxistvegan ( 2018-11-27 21:56:01 +0300 )edit

Thanks for the suggestions - restarting doesn't change things, and I've been through the MMS settings to try different sizes and such. I guess that means it's up to Jolla support at this point with the logger; I was just hoping to find a way to do this myself.

rancidpie66 ( 2018-11-30 01:11:52 +0300 )edit
0

answered 2019-04-01 02:16:45 +0300

Guillaume L. gravatar image

Same here with SFR in France. I am unable to send MMS since I installed SailfishX. Worked fine on Jolla 1.

edit flag offensive delete publish link more

Comments

Found the fix somewhere in the conversation thread :-)

Guillaume L. ( 2019-04-01 02:20:22 +0300 )edit

What was the solution?

Mohjive ( 2019-04-02 14:11:38 +0300 )edit
1

Change APN from "mmssfr" to "sl2sfr" (Settings > Mobile connection > MMS access point) and message size from "Very big" to "Big" (Settings > Applications > Messages)

Guillaume L. ( 2019-04-02 16:15:26 +0300 )edit

Thank you. Should maybe posted in your answer, so that it's easy to find. And should probably be merged upstream to fix the issue for good.

Mohjive ( 2019-04-02 19:59:52 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2017-11-09 03:24:18 +0300

Seen: 3,001 times

Last updated: Apr 30