Ask / Submit
1

Proximity sensor active during phone call with headset

asked 2014-01-20 05:38:43 +0300

droll gravatar image

updated 2014-01-20 13:09:09 +0300

lk gravatar image

When i'm in a phone call using a bluetooth headset, the proximity sensor is active. This makes it difficult for me to use the phone while I am talking.

Can you please disable the proximity sensor while bluetooth headset is used in an active call?

Thanks

edit retag flag offensive close delete

Comments

2

As a configuration, maybe. As a default that would be a bad idea. Most of the times I'm on the phone, using a Bluetooth headset, I keep the phone in my pocket, and not having a proximity lock could present some interesting events.

Mohjive ( 2014-01-20 09:35:39 +0300 )edit
1

@Mohjive: Having the phone in a pocket is a separate case as the display stays off as long as the proximity sensor is covered. The blank-due-to-proximity kicks in after the call has been answered and the display is on.

spiiroin ( 2014-03-16 12:33:57 +0300 )edit

@spiiroin: I don't see what's different between what you said and what was said previously.

I could expand my use case. Sometimes I answer the call with the headset, and keep the phone in my pocket, but sometimes I pick the phone up, answer the call and put it back into my pocket. Even in the latter case I want the display (and touch) to be disabled by the proximity sensor. I would like the proximity sensor to always disable the screen/input.

Mohjive ( 2014-03-16 18:55:41 +0300 )edit

@Mohive: Generally: the display will not turn on while the ps is covered, other that that the proximity state does not matter -> any part of display can be poked without it suddenly blanking. Exception: active call, no speaker or headset -> display turns on/off based on the proximity (assumed=at-ear) state.

Proximity blanking occurs with speaker/headset = deviation from intended behavior = bug. Someone wanting to keep/extend the "faulty" behavior = new feature, possibly opt-in via settings.

spiiroin ( 2014-03-17 09:30:07 +0300 )edit

@spiiroin: that assumes that I knew that the proximity sensor should be disabled during a call with the headset was the intended behavior. That information was new to me.

But I guess that is ok, as long as the display does not wake as long as the proximity sensor is covered. I've learned to turn of the display using the on/off switch before putting it back into my pocket during a call, and as long as it stays of I'm fine with that.

Mohjive ( 2014-03-17 10:39:33 +0300 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2014-03-16 12:27:05 +0300

spiiroin gravatar image

Earlier changes to in-call audio routing broke the proximity blanking policy. The behavior with speaker is fixed in the upcoming mar14 update. The headset fixes missed the release time window for that, but will be coming later on.

See also: https://together.jolla.com/question/22059/bug-screen-goes-off-phone-call-on-speaker/

edit flag offensive delete publish link more
0

answered 2014-01-20 06:47:03 +0300

droll gravatar image

actually let that be any phone call. i sometimes put thr phone into speaket mode and tilt it into landscape mode and my hand accidentally covers the proximity sensor.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2014-01-20 05:38:43 +0300

Seen: 787 times

Last updated: Mar 16 '14