Switch SIM: no connection

asked 2017-11-09 11:01:09 +0300

arjenbalfoort gravatar image

updated 2017-11-09 11:41:00 +0300

I've recently changed providers and with that I had to change the SIM card. After I enter the PIN code my Jolla fales to register the SIM with the provider. When I try that same SIM card in another phone it works.

I found several references to the ofono service and re-created the /var/lib/ofono directory as mentioned here: https://together.jolla.com/question/148246/bug-new-sim-crazy-behavior/

After several reboots there was no change and the ofono service gave me this status:

$ devel-su
# systemctl status -l ofono.service
● ofono.service - Telephony service
   Loaded: loaded (/lib/systemd/system/ofono.service; disabled; vendor preset: enabled)
   Active: active (running) since Thu 2017-11-09 09:32:29 CET; 5min ago
 Main PID: 1004 (ofonod)
   CGroup: /system.slice/ofono.service
           └─1004 /usr/sbin/ofonod -n --nobacktrace --noplugin=he910,dun_gw_bluez5,hfp_bluez5,hfp_ag_bluez5,cdma_provision,bluez5,isimodem,n900,u8500,qmimodem,gobi,cdmamodem,isiusb,nwmodem,ztemodem,iceramodem,huaweimodem,calypsomodem,swmodem,mbmmodem,hsomodem,ifxmodem,stemodem,dunmodem,hfpmodem,speedupmodem,phonesim,telitmodem

Nov 09 09:32:54 Sailfish ofonod[1004]:   Type: OFONO_GPRS_CONTEXT_TYPE_INTERNET
Nov 09 09:32:54 Sailfish ofonod[1004]:   Username: '(null)'
Nov 09 09:32:54 Sailfish ofonod[1004]:   Password: '(null)'
Nov 09 09:32:54 Sailfish ofonod[1004]: Name: 'KPN MMS'
Nov 09 09:32:54 Sailfish ofonod[1004]:   APN: 'portalmmm.nl'
Nov 09 09:32:54 Sailfish ofonod[1004]:   Type: OFONO_GPRS_CONTEXT_TYPE_MMS
Nov 09 09:32:54 Sailfish ofonod[1004]:   Username: '(null)'
Nov 09 09:32:54 Sailfish ofonod[1004]:   Password: '(null)'
Nov 09 09:33:00 Sailfish ofonod[1004]: export_entries_one_storage_cb with ME failed
Nov 09 09:35:13 Sailfish ofonod[1004]: data reg changed 2 -> 0 (unregistered), attached 0

I searched for "export_entries_one_storage_cb with ME failed" and this brought me to this post: https://together.jolla.com/question/125494/mobile-connection-used-to-work-but-is-now-broken/

The difference is that my new SIM functions correctly in another phone. Only not in Jolla.

Does anybody know how to go from here?

[EDIT]

After removing the battery for a while and booting the last three lines were these:

Nov 09 10:35:17 Sailfish ofonod[974]: data reg changed 2 -> 3 (denied), attached 0
Nov 09 10:35:33 Sailfish ofonod[974]: data reg changed 3 -> 2 (searching), attached 0
Nov 09 10:35:52 Sailfish ofonod[974]: data reg changed 2 -> 0 (unregistered), attached 0
edit retag flag offensive close delete

Comments

  1. Install oFono Logger from Jolla Store
  2. Run oFono Logger. Pull down to see any items hinting that the app has a way to fix something.
  3. If nothing to fix, use the phone and SIM trying to do something network related. Send the collected logs using the pull down menu (it has an email address pointing to Jolla R&D).
jovirkku ( 2017-11-09 14:07:52 +0300 )edit

I installed oFono and ran it as you suggested. I then cleared the log and rebooted to see what's happening...and I had a connection! Is it possible that clearing the log can do that?

arjenbalfoort ( 2017-11-09 15:42:31 +0300 )edit