How to synchronize Google calendar?

asked 2017-11-11 17:34:02 +0200

jsommer gravatar image

My Intext Aqua Fish with SailfishOS 2.1.2.3 doesn't sync Google calendar. CalDAV is synced, but created duplications. These to problems are well known. The last posts according Google calendar are from 2014. Thus I would expect, that this bug is already fixed.

My workaround is currently to delete the and create the Google account regularly. But - well - this is not the comfort I expect form a modern mobile operation system.

Has someone a solution?

edit retag flag offensive close delete

Comments

I have no experience in Aqua fish and could not find the previous posts.

Have you checked Google account is active and there is no need to update sign-in credentials?

potski ( 2017-11-12 22:56:34 +0200 )edit

Thanks for your response. Yes, I tried several things:

  • Deactivating and activating the Account
  • Forcing synchronisation in the calendar app and the account settings
  • Deactivating and activating the specific calendar in the calendar app
  • Some combination of these steps

Here are the related threads:

I'm not sure, whether the reason is a multi-day-event or event-series.

jsommer ( 2017-11-13 10:30:50 +0200 )edit

Hi. I am affected this issue too :-/ It is really annoying issue when you are using Sailfish OS on primary phone and Google as primary calendar backend. How can we help to fix this issue? I am C++ developer, but I am not sure where to start.

  • Is there any way howto get logs from calendar synchronisation? (systemd journal is almost empty)
  • How the synchronisation is done? D-Bus daemon starts some short-living process for that?
  • It is possible to reproduce and debug it somehow on local Linux machine?
  • On calendar wiki entry (https://sailfishos.org/wiki/Calendar) is note about plan to migrate from mKCal to QtPIM api. Is there some progress with this transition? Is there some time plan? Should I invest energy to debugging mKCal and KCalCore or should I wait for new shiny QtPIM backend? Who will do this transition? Someone from Jolla or from Mer community?

Update: I just updated /etc/systemd/*.conf to get logs. It seems that I am facing the same issue described here: https://together.jolla.com/question/162657/google-calendar-not-syncing-new-events/?sort=votes&page=1 google server responds with error: updatedMinTooLongAgo

Karry ( 2018-01-16 19:57:17 +0200 )edit
1

Currently I unchecked the calendar synchronisation for my Google account and add the Google calendar as additional CalDAV account. The CalDAV URL of Google calendar is https://www.google.com/calendar/dav/any.address@gmail.com/events. It also works for non gmail addresses of a corporate account.

jsommer ( 2018-01-16 22:55:47 +0200 )edit