Ask / Submit

Update from to fails on Jolla 1

asked 2017-11-17 14:54:21 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2017-11-18 00:34:07 +0300

olf gravatar image

The OS update function on my Jolla 1 with SFOS v. informs me that the new version is available. After downloading the installation file and giving the Install command, the black screen with the progress bar shows up. After indicating the very narrow white band for the initial position, the progress bar increases once with a longer step, whereafter the process stops and a new warning screen is shown telling me that the installation can not be completed and I then have to confirm "OK" for the phone to make a restart (after which I'm back to v.

I'm at a loss about what to do now.

edit retag flag offensive close delete



Same here from to - it failed first go, got the same warning you got, I started the process again and it worked okay no problem. Perhaps to simply try again.

Edz ( 2017-11-17 15:26:10 +0300 )edit

Same here, too. But I didn't even bother to remember, just retried and forgot.

lakutalo ( 2017-11-17 15:28:40 +0300 )edit

Happens to me with almost every update on Jolla1, but always works at second try. I also don't bother anymore :)

Spark ( 2017-11-18 03:11:12 +0300 )edit

Seems to be a theme emerging in this section of comments ~ "If at first you don't succeed, try again"

Edz ( 2017-11-18 11:52:18 +0300 )edit

Hey, retried 3 times, after that it started to install as it should.

Konn ( 2017-11-18 11:53:41 +0300 )edit

3 Answers

Sort by » oldest newest most voted

answered 2017-11-17 15:13:05 +0300

atlochowski gravatar image

updated 2017-11-17 15:14:22 +0300

Check allocation:

btrfs-balancer allocation

if it's required make a balance:

btrfs-balancer balance

If this doesn't help try to force update

ssu re
version --dup

Make sure that you unapplied all patches before force upgrade.

edit flag offensive delete publish link more


Thanks for your reply! I guess that for many readers here it might be of help.

However, I'm an ordinary user who uses this phone not for doing hacking activities, but because of the UI and even more for getting away from some gigantic companies that sucks privacy out of our lives (and decency out our society), I have never used the the text interface and will regrettably need some even more detailed instructions if I should be able to follow up on the advice

espen ( 2017-11-17 15:22:18 +0300 )edit

@espen usually this is being done in background while preparing update. So really just retry. Hope this helps.

lakutalo ( 2017-11-17 15:31:12 +0300 )edit

@espen: This article explains how to enable the Developer mode and set the SSH password. Terminal app will then appear in the end of the app grid. It is there that you should type the commands proposed by @atlochowski. One-by-one, confirmed by tapping the Enter key. Command "devel-su" requires the SSH password (it is not echoed to the display).

jovirkku ( 2017-11-17 15:36:50 +0300 )edit

@espen: Handy tip if not used to Terminal, tapping three horizontal bar icon at top right of screen gives option to make Font size bigger.

aspergerguy ( 2017-11-17 15:52:22 +0300 )edit

@akutalo: Rest assured that I've tried 4 times before I gave up and posted my question.

@atlochowski (and others): "btrfs-balancer allocation - if it's required make a balance" How do I now that? (What does "balance" mean her?) The result of the command is the information that Allocated is 55 %, 14,7 GB total and 8,1 GB used, I would suppose that those figures are not alarming in any respect and that I should then just continue to the forced upgrade(?).

@spergerguy: That was indeed a very handy tip for my old eyes. Thanks!

espen ( 2017-11-17 16:28:05 +0300 )edit

answered 2017-11-18 02:00:18 +0300

flow gravatar image

This may certainly be a coincidence, but for the last three or four releases I was only able to update after increasing display uptime from 30 seconds to 10 minutes. I did various attempts that would fail just like yours, trying out different settings. In the end I opened display settings and changed the Sleep after 30 seconds to Sleep after 10 minutes - and it worked.

Not very substantiated, I know, but if you have your display set to a short uptime, it could be worth to give it a try. I probably got the idea from a similar post here, but I can't find it right now.

edit flag offensive delete publish link more


Yes, I have such short time set, but this has clearly not created any problem with previous updates.

espen ( 2017-11-18 02:47:02 +0300 )edit

answered 2017-11-21 13:45:14 +0300

Vesart gravatar image

I downloaded the new OS version and started the installation. After pressing OK to request of restarting the phone, it started to reboot but after a while it stopped, screen went black and it rebooted again. This seems to continue forever. What shall I do?

edit flag offensive delete publish link more


Maybe you belong to this thread: Could you try to find out if your update failure is related to that case? (some web package not updating)

lakutalo ( 2017-11-21 14:22:02 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2017-11-17 14:54:21 +0300

Seen: 718 times

Last updated: Nov 21 '17