We have moved to a new Sailfish OS Forum. Please start new discussions there.

Sailfish X: Android apps cannot use mobile data

asked 2017-11-17 21:13:03 +0300

PK gravatar image

updated 2019-02-07 11:09:07 +0300

jiit gravatar image

I have two Xperia X phones running Sailfish X that cannot use mobile data in Android applications. Android applications work great over Wifi but cannot detect the connection over mobile data. Native Sailfish apps work perfectly with both mobile data and wifi connections.

I have had this problem since day 1, but thought it was already being addressed in the / Kymijoki update due to this in the release notes:

---Android apps can recover mobile data connection.

However, after updating both of my Xperia X devices, the problem remains exactly the same. HereWeGo and Skype are two example apps, but I tried a dozen packages and none of the Android apps would work with mobile data. The one exception is Firefox and I have no good explanation for that.

I've tried everything I can think of but nothing has solved or even improved the situation. This may be a bug. Any troubleshooting tips or workarounds would be sincerely appreciated.


edit retag flag offensive close delete

3 Answers

Sort by » oldest newest most voted

answered 2017-11-19 15:28:36 +0300

PK gravatar image

updated 2017-11-19 15:31:09 +0300

After more researching and testing, I have found a solution. This appears to be an operator-specific problem (sort of). My mobile provider (T-Mobile USA) has two different APNs, fast.t-mobile.com and epc.t-mobile.com. "fast" is their newer network. The solution to my problem with Android apps not being able to access mobile data was simply to change my data APN to epc.t-mobile.com.

This is quite strange. I have been using the "fast" APN to access mobile data successfully in all Sailfish apps and it also works fine with the Firefox android app. I further use that as the MMS APN with no problems, but it turns out that 99% of my Android apps cannot access the mobile connection when it's on fast.t-mobile.com regardless of protocol setting. For what it's worth, a pure android phone with my SIM card can successfully access mobile data on "fast." Oh well, it's very weird, but at least the problem is resolved. I think using Sailfish on T-Mobile USA is a good experience overall but the Data & MMS settings are very particular with this combination of provider & OS. I'm just grateful to finally have a great Sailfish-powered device that supports my local bands.

For the record, here are my settings:

T-Mobile Data
Auth: None

T-Mobile MMS
Auth: None
Proxy: Blank
Port: Blank
MMS message center: http://mms.msg.eng.t-mobile.com/mms/wapenc
edit flag offensive delete publish link more


Hi, where do you change these settings? Which file? It's been 2 months I'm struggling to get my Xperia working when I'm abroad...

Marius ( 2018-01-13 17:38:02 +0300 )edit

These settings are in the Settings app under Cellular Network->Data Access Point and Cellular Network->MMS access point.

It is interesting that you mention roaming abroad. The original settings I listed work great in the US. However, I am currently in Ecuador and had to modify my MMS APN to epc.t-mobile.com (instead of fast) in order for MMS to work properly. All other settings did not have to be modified and I've had zero trouble with data or MMS roaming on the local CLARO and Movistar networks. Good luck!

P.S. Important note -- I am using T-Mobile USA. If your own T-Mobile provider is in Europe, this information may not apply to you.

PK ( 2018-01-13 18:45:06 +0300 )edit

answered 2019-02-07 08:12:52 +0300

zsiraf gravatar image

updated 2019-02-07 08:13:23 +0300

I have an Xperia XA2 (H4113) device with one SIM card and SFXOS beta. Android apps can't use the mobile data, listed below: Telegram Skype Viber Messenger

It shouldn't be general problem, because Firefox works well. It can open any webpage, play videos, etc...

I'd be grateful for any hint, to solve this problem.

edit flag offensive delete publish link more



please take a look at the release notes, it's a known issue

balta ( 2019-02-07 08:24:56 +0300 )edit

Hi, is there any solution for this problem? I am using

Runningtrilo ( 2019-10-04 11:49:33 +0300 )edit

answered 2017-11-17 22:51:17 +0300

GD gravatar image

I had this for a while on my Jolla1 turned out to be a setting I set with an android utility that turned of mobile data. try installing a utilities app. sorry cann't remember the utility I used.

It only effected android apps.

edit flag offensive delete publish link more


Thanks very much for the tip! It didn't resolve my problem (using Android assistant) but I will keep this in mind for possible future cases. Thanks again.

PK ( 2017-11-19 15:28:32 +0300 )edit

Perhaps https://together.jolla.com/question/51695/bug-android-apps-connection-problems-with-wlan/?answer=53791#post-id-53791where wifi_on is set to 0 (representing off) and/or airplane_mode_on set to non-zero (zero represents not on, others represent airplane mode)

Izzak ( 2017-12-18 00:12:35 +0300 )edit
Login/Signup to Answer

Question tools



Asked: 2017-11-17 21:13:03 +0300

Seen: 970 times

Last updated: Feb 07 '19