Ask / Submit
7

google sync Saifish X

Tracked by Jolla

asked 2017-11-20 15:52:03 +0300

danfin gravatar image

updated 2017-11-22 11:15:38 +0300

jiit gravatar image

Well, it does not work here. Is everybody else happy? When adding a Google account, phone reads in all data but never syncs after that. Reset sync does not help, so far. Deleting sync files no success. So I tried to CalDAV / CardDAV my google account. This messages: 'oops, problem with account creation'. Reset to factory settings and OS 2.1.3.5 will not help either.

edit retag flag offensive close delete

Comments

You create a new account of Google and synchronize with it. What result?

zuyev ( 2017-11-20 18:23:22 +0300 )edit

I create a new account of Google and syncronize, my phone will read in all calendars and contacts properly. If I then add a event or a address on the phone this will not sync. Add a event on the dekstop computer will not sync. SailfishX seems to just read the data once.

danfin ( 2017-11-21 10:06:15 +0300 )edit

Yes, never syncs google calendar for me with Sony X, I have to manually sync particular calendar day. Yet it works automatically on Jolla1

richie ( 2017-11-22 15:48:44 +0300 )edit

now what happened to Google sync? on 2.1.3.7 my Googlesync would run fine on JollaC but not on SailfishX ... on 2.1.4.14 my Googlesync does not work on both JollaC and SailfishX ... guess i'll try do down grade and see if it works again, at least on the C.

danfin ( 2018-03-08 09:14:07 +0300 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2017-11-21 05:35:27 +0300

jsommer gravatar image

I have the samle problem with my corporate Google Account. Emails are partly synced. I can see new emails on my Sailfish phone. Unfortunately deleted emails in the Sailfish clients are not synced. So Ihave to remove them later in another desktop client.

The calendar sync is only working for the first time after I have created the account. CalDAV works partly. Are you using this setting?

https://www.google.com/calendar/dav/<your-email-address>/events</your-email-address>

To synchronize after the initial sync process, I need to manually sync, deselect and select the Google calendar again in the Sailfish calendar app. Not really comfortable, but it workd.

edit flag offensive delete publish link more

Comments

I tried the Saifish provided settings, Unsername, Password, Server, without adding a optional path. But, I'd prefer to simply add a google account. On my Jolla C with OS 2.1.3.5 this works fine and syncs ok both contacts and events.

danfin ( 2017-11-21 09:17:18 +0300 )edit

I agree. It should be as simple.

If you want to add Google calendar as CalDAV you need to add the path.

jsommer ( 2017-11-21 10:45:56 +0300 )edit

that path <your-email-address>/events</your-email-address> does not work. No calendars show up in my calendar.

danfin ( 2017-11-21 11:13:37 +0300 )edit

I’m so sorry. For any reasons my editor has added the xml close tag. Here is an example for the fictive account hello@gmail.com. It works also for corporate accounts with non gmail addresses.

https://www.google.com/calendar/dav/hello@gmail.com/events

jsommer ( 2017-11-21 11:41:40 +0300 )edit

thank you. Now tried this syntax but I still get a oops, problem with account creation message. I will try some more tomorrow, to make sure there's no typo or something.

danfin ( 2017-11-21 14:19:52 +0300 )edit
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2017-11-20 15:52:03 +0300

Seen: 424 times

Last updated: Nov 21 '17