roaming and dataroaming wouln't work at all in switzerland

asked 2017-11-21 19:55:02 +0300

sbo gravatar image

updated 2017-11-22 10:28:42 +0300

jiit gravatar image

I am experiencing serious problems with roaming. My Jolla Phone wouldn't establish any roaming or data-roaming connection in Switzerland! I am using a german SIM-card (premiumsim.de). Roaming and dataroaming works perfect with the very same simcard, when I use a regular Android-phone.

Since I am daily commuting to switzerland, my XperiaX is pretty useless for me at the moment....

Any plans to fix this in a future update?

edit retag flag offensive close delete

Comments

Did you enable roaming in the "Mobile network" settings? Please also provide the model you are experience the problems with and check if the access points are correct for the network you are using.

I'm not aware of any issues with the mobile networks in Switzerland, there are reports that those are working fine and I personally did not had any problems with Sunrise and Salt on the Jolla C or Salt on the Xperia X.

ghling ( 2017-11-21 21:52:33 +0300 )edit

"Mobile Network" was enabled. Also "Roaming enabled". Model: Xperia X. Firmware: 2.1.3.7 The phone wirked fine till the border. Then it wouldn't pick up the swiss network, although Roaming was enabled.

Without "Data Roaming" the Phone would somtimes connect to the Salt-Network, but without "Data". But as soon the connection got disconnected due to bad connection, it wouldn't reconnect at all..... even manually I coudln't connect, though Salt was displayed in the Networks list. After a while of trying, it said "Verbindungsproblem". Also changed the APN to "Internet", as suggested in other threads.

The phone workes fine in the home network (O2/eplus) including data. It is just the roaming that doesn't work.

sbo ( 2017-11-21 22:08:17 +0300 )edit

This sounds strange. If you can't even manually connect to any network it sounds like this may be somehow a restriction with your SIM. Is there a possibility that you can try a connection with a swiss SIM (maybe a prepaid one) to check if this works?

I myself don't have any issues with connection to Salt natively nor connecting to roaming networks in Germany.

ghling ( 2017-11-21 22:15:07 +0300 )edit

I have a similar issue. First I thought it is a problem with the operator (Blau in Germany), but after checking with them I think now that it maybe something with the system (especially that it worked well before when I had normal android on the Xperia). I travel often to Italy, France, Switzerland and either rarely I get any connection (for instance last week in Rome I had connection at the airport but then it disappeared for the whole day, appeared again when I was in a popular museum and then it was gone again until the airport...). Switching on/off plane mode, rebooting the phone does not help. Data transfer is not crucial for me, but ability to call or send sms - well, it is very basic.

Marius ( 2017-12-16 12:33:02 +0300 )edit