Ask / Submit
0

Sony Xperia X Bootloop after lipstick-restart

asked 2017-11-26 08:13:24 +0200

AA-0001 gravatar image

updated 2017-11-26 08:38:41 +0200

Hello,

I've tried to find a solution to make the launcher-combined-patch work. In this endeavour, I uninstalled all my patches and I did this commands :

devel-su

rm -rf /usr/share/lipstick-jolla-home-qt5 pkcon install lipstick-jolla-home-qt5 exit

systemctl --user restart lipstick.service

After that, the screen was white and black and then nothing. Restarting the phone didn't solve the problem obviously. I assumed that it was a bootloop.

Can someone help me with that ?

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted
0

answered 2017-11-26 10:38:42 +0200

ghling gravatar image

updated 2017-11-26 10:38:55 +0200

What was your intention when deleting the lipstick folder? No wonder lipstick (and thus the whole UI) wouldn't run anymore.

I suspect you wanted to reinstall the package afterwards!? In this case pkcon install lipstick-jolla-home-qt5 is not enough since you did not remove the package (I'd suspect, pkcon told you something like "package already installed"). The first thing I would try is booting up the recovery and then reinstall the package:

pkcon remove lipstick-jolla-home-qt5

pkcon install lipstick-jolla-home-qt5

One potential issue doing this could be that this probably breaks dependencies, so pkcon wouldn't allow you to do this. I'm currently not aware of the option to force remove packages, maybe someone can jump in on that?

Alternatively, you alway can take the easy way and reflash your device.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2017-11-26 08:13:24 +0200

Seen: 184 times

Last updated: Nov 26 '17