Ask / Submit
23

Microsoft Exchange not working on Xperia X

asked 2017-11-30 10:26:18 +0300

AlanBreen gravatar image

updated 2018-05-27 08:40:40 +0300

I have Microsoft Exchange account set up on my Xperia X. It seemed to be working OK prior to the latest OS update though I cannot be sure about that.

Recently I noticed it wasn’t syncing emails nor calendar, I don't sync contacts. Yesterday I uninstalled the account and reinstalled it. Syncing was restored for a while but it’s stopped syncing again.

I’ve tried changing the provisioning and security certificate settings and tried a different server name, (eas.outlook.com and s.outlook.com) I’m using Outlook as my mail server.

Has anyone else had this problem?

Any ideas for a fix?

Thanks

Update May 27 2018

I still have issues with the Microsoft Exchange account. It stops syncing until I reboot the phone, then it works perfectly for several days then stops syncing again. Note, I only turn my phone off when I have a problem so the up time can be several weeks.

I have tried different server addresses, I've uninstalled the account both on the phone and removed the device from my Outlook.com webpage. I've allowed the account to be set up an automatically allocating the server automatically. Every time the outcome has been the same. The account syncs perfectly for a while then it stops syncing.

I don't know what else I can try. Will the ofono log show what's going on?

edit retag flag offensive close delete

Comments

2

Exchange Activesync seems to be somewhat unreliable on both my Aquafish (Jolla C) and my Xperia X. From time to time synchronization simply stops (I am not referring to the "synchonization failed" status in the email app cover that is almost always displayed - in this case synchronization stills works).

In my case, killing the /usr/bin/sailfish-eas process usually re-initializes the synchronization without reboot.

For me, Jolla's EAS got more stable since I avoided to synchronize additional clients with that same Exchange account (e.g. Windows Mail, Android, Evolution with EAS). Especially the typical double calendar items, and one-hour shifts of events are gone!

ziellos ( 2017-11-30 11:00:38 +0300 )edit

Are you saying a reboot of the device restores syncing?

Please forgive my ignorance, how do you kill sailfish-eas process?

Thanks

AlanBreen ( 2017-11-30 11:08:26 +0300 )edit
5

I have this problem on my Jolla C using company Exchange. I noticed that rebooting restored the syncing, so I found out a workaround command to avoid rebooting: systemctl --user restart sailfish-eas.

mattikbk ( 2017-11-30 11:20:24 +0300 )edit

@mattikbk: great! Even better than the kill approach, since it doesn't require to be root.

ziellos ( 2017-11-30 11:33:36 +0300 )edit
1

My sync seems to work (sailfishx 2.3.1.7), but if I try any other sync setting than "manual" or "always up to date", the setting changes back to manual.

In addition, I have only one exchange account, but in Calendar-app there is two exchange calendars in the calendar list: "Calendar" and "test calendar". Luckily test calendar is empty, so no duplicate entrys.

hsjpekka ( 2018-01-21 22:41:24 +0300 )edit

12 Answers

Sort by » oldest newest most voted
2

answered 2017-11-30 23:10:21 +0300

Rudge79 gravatar image

I use outlook.office365.com as server adress. I don't experience such synchronization problems. Maybe you can try it.

edit flag offensive delete publish link more

Comments

1

That is the server address I have used since day one of using SFX and I still get the periodic non syncing. A reboot restores the syncing but the client is unreliable in general and a poor implementation.

Desmo ( 2017-12-01 01:36:45 +0300 )edit

Today it's started syncing again :) but two events have synced into the Xperia one day late :(

AlanBreen ( 2017-12-01 11:30:03 +0300 )edit
1

answered 2017-12-01 11:57:42 +0300

Rudge79 gravatar image

settings I use: -port 443 -accept all SSL certificates -NO provisioning

edit flag offensive delete publish link more

Comments

Thanks Rudge79!
Used exactly that settings and it worked. Provisioning ON can be set after account was created with NO provisioning.

Ykä ( 2018-04-24 19:02:29 +0300 )edit

Accepting all certificates is a very bad idea! With Office 365, which handles these things properly, it should never be used.

Provisioning however may prevent account creation, and it doesn't even tell you what is the cause, so I have that not checked.

Direc ( 2018-06-13 00:14:58 +0300 )edit
1

answered 2018-01-25 13:36:38 +0300

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

updated 2018-01-25 13:36:38 +0300

DiBasse gravatar image

This problem has occurred on Jolla1, Intex Aquafish and is now on my Xperia X running Sailfish X. I fear this is an old issue that has not been properly coded in the first place. When changing the password it seems to occur more often.

Ideas why this happens anyone?

edit flag offensive delete publish link more

Comments

I'm having a similar problem with my Jolla. As soon as my password changes, it won't change in the Jolla settings and I can no longer access that account. Very frustrating as I need to get into my work emails and now can't. Grrrrr...

Meanfluff ( 2018-01-26 20:04:13 +0300 )edit
1

answered 2018-06-12 15:10:07 +0300

ehakkarainen gravatar image

Has never worked properly - and (I'm sorry to say) it seems never will :( On a good day will sync contact info - otherwise I suggest using Outlook for Android (not glad to suggest, but works)

edit flag offensive delete publish link more

Comments

agree, I switched to outlook for android a while ago ( gasp .... :/ )

clovis86 ( 2018-06-12 15:14:57 +0300 )edit
2

The problem with apps like "Outlook for Android" is calendar entries do not sync into the native calendar and that is very important for me.

I need the native email client to work properly. MS Exchange has worked on native email clients on all other devices I've had, I see no reason why it shouldn't be possible to have it work properly on Sailfish.

AlanBreen ( 2018-06-13 09:06:57 +0300 )edit
0

answered 2017-12-01 12:00:46 +0300

My workplace upgraded to office365 and since then I got can no longer use exchange no matter what settings I try.

edit flag offensive delete publish link more

Comments

1

We had a similiar situation, I had to completely remove Exchange account from Sailfish and re-create it (just modifying settings of the existing account didn't help). So far it has worked 100% since then. I'm using outlook.office365.com as server address.

goldenm ( 2017-12-29 22:58:49 +0300 )edit

Thank you, that fixed my problem. I just kept editing settings but deleting it and creating it from scratch worked great.

Mariusmssj ( 2018-01-25 21:21:52 +0300 )edit
0

answered 2017-12-29 21:52:46 +0300

sunburnedpenguin gravatar image

I too am having problems accessing my company Exchange server via Jolla's native email client with Exchange plugin. Mine seems to be caused by the provisioning check while adding the account. I've tried multiple different combinations for the Device Lock to no avail.

I was able to sync using the Android app Bluemail, but because of the lack of Google Play(-You-For-A-Fool) Services, pushes (which unfortunately also includes sending emails) don't work, rendering the application virtually useless.

Anyone have an idea why Bluemail would pass the provisioning check while Jolla's Exchange implementation does not?

edit flag offensive delete publish link more

Comments

our company uses outlook.office.com and I can not connect with the Exchange plugin either.

deloptes ( 2017-12-30 13:44:34 +0300 )edit
0

answered 2018-01-25 10:14:17 +0300

goliatl gravatar image

I use outlook.office365.com with port 443, secure connections selected. With my account the username and email are different, perhaps it is the same for you...

edit flag offensive delete publish link more
0

answered 2018-01-25 15:19:57 +0300

updated 2018-01-25 15:20:17 +0300

I cant sync my outlook calendar too, I need to delete the account and recreate to sync the new entry

edit flag offensive delete publish link more
0

answered 2018-02-11 15:47:57 +0300

twotty gravatar image

I'd the same problem. but after remove and recreate the account, my calendar is sync. i have always the display problem about frequency witch stay to "manually" sync but it's not manualky. my new schedule are created in both side.

edit flag offensive delete publish link more
0

answered 2018-03-14 11:06:58 +0300

msknight gravatar image

I had three accounts. Two pop3 accounts, and an Exchange account. I had restored from backup, from a Jolla 1 to an Xperia X. Every morning, the last e-mail was from 7:11am and by the time I noticed at 9am, it was jammed and wouldn't update.

The other two accounts were on the default to sync every 30 minutes. I changed these to my usual custom config... off peak as manual. On peak, every 15 minutes between 6am and 9pm ... and I noticed that the default clock time for custom peak period sync was 9am, but when I went in to edit it, it was 8am.

So my suggestion is that if you've got other accounts that are also synching... change their synch times... or check to see if the Exchange account stops synching at around the time that the others synch, or if it stops at 8am-ish

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
11 followers

Stats

Asked: 2017-11-30 10:26:18 +0300

Seen: 2,259 times

Last updated: Aug 20