Ask / Submit
10

[Bug/Feature] Email attachments get saved automatically to Gallery even if it ist Spam!

Tracked by Jolla

asked 2018-01-16 14:55:35 +0300

Raymaen gravatar image

updated 2018-01-16 18:37:03 +0300

[Xperia X] Yesterday i received a Spam E-mail with 2 attachments. (a Whiterussian Girl looking for marriage... WTF???) One attachment was a nudepic and the other was a "site.html" (what ever that was, virus?) I opened the Email and when i saw the minimized noodepic in the attachments, i deleted the mail without even reading it. Today I searched for some pictures I took last week to show them to my kolegue. And when I opened the gallery there it was... the nudepic. How ist that sh..t possibe?? Why do the attachments download automatically? What about the site.html file? Where is it? In my opinnion it is a security problem, when attachments get downloaded automatically without my knowledge. What if it was a virus constructed to infiltrate Sailfish OS (or what ever). Do i even have a chance to not download every garbage that is attached to an E-mail? I know some of you are laughing while reading, but its actually not funny. ;-) How to deactivate the automatic download of attachments?

Edit: Appsetting for automatic download to gallery was disabled. SailfisX issue? Or general?

Edit 2: Setup: POP . I opened the deleted spam E-mail in the deleted folder and without touching any attachment that stupid nudepic got loaded again into my Gallery. So there was no activation of attachment download by mistake. I have all the attachmens from 18.10.2017 in my Downloads/Email-Attachments folder without having the automatic download enabled. it must be a Bug. even with POP-Setup.

edit retag flag offensive close delete

Comments

1

Is auto image download off under Settings > Apps > Email ? Or did you tap on the images by chance?

jiit ( 2018-01-16 15:23:03 +0300 )edit

no i did not...

Raymaen ( 2018-01-16 15:32:47 +0300 )edit
1

hey i got the same email :P

DarkTuring ( 2018-01-16 23:13:00 +0300 )edit

5 Answers

Sort by » oldest newest most voted
4

answered 2018-01-16 15:20:58 +0300

lakutalo gravatar image

updated 2018-01-16 15:24:39 +0300

Check Settings -> Apps -> Email -> deactivate "Download images automatically"

If it is off, this is a severe bug!

edit flag offensive delete publish link more

Comments

That setting was deactivatet, i just looked.

Raymaen ( 2018-01-16 15:23:32 +0300 )edit

Have you ever activated it?

lakutalo ( 2018-01-16 15:25:10 +0300 )edit

no i did not, i think it was already deactivated when i flashed Sailfish X (but i don't remeber exactly)

Raymaen ( 2018-01-16 15:42:07 +0300 )edit
1

Could you also check if attachments of all of your emails have been downloaded? Or since when?

lakutalo ( 2018-01-16 16:02:01 +0300 )edit
1

since 18.10.17 every attachment got saved in the downloadfolder. see Edit 2.

Raymaen ( 2018-01-16 18:34:07 +0300 )edit
1

answered 2018-01-16 15:21:20 +0300

jayki gravatar image

updated 2018-01-16 15:21:32 +0300

Just disable automatic Download in Settings->Apps->Email

edit flag offensive delete publish link more
2

answered 2018-01-16 15:27:39 +0300

Pekka Vuorela gravatar image

Why do the Attachments download automatically

They don't. I'm guessing you might have clicked the attachment once to make it downloaded.

edit flag offensive delete publish link more

Comments

hmmm... maybe by accident when i was trying to close the app or switch to the next email. did not realise the download. don't you get it showed when you download an attachment normally? or does it simply download when its clicked without any notification?

Raymaen ( 2018-01-16 15:46:27 +0300 )edit

New email, click on attachment item -> download starts and you get to shown a progress bar on the attachment item. Click on downloaded attachment -> opened in application.

If you clicked attachment there and immediately closed the app / switched to another app / left the email, you don't get to see progress.

Pekka Vuorela ( 2018-01-16 15:53:54 +0300 )edit
2

Are you using POP to fetch emails? By default with POP, attachments are always automatically downloaded. It's not the case for IMAP.

Damien Caliste ( 2018-01-16 17:48:47 +0300 )edit

Yes i have POP set up.

Raymaen ( 2018-01-16 18:25:02 +0300 )edit

Well, @Raymaen, if you are using POP3, it do probably work as it should: The e-mails are downloaded from mail server and (normally) deleted there. Although, if the option of not automatically download images is provided in the settings, then this statement is certainly not very well chosen or not clear enough for users who are not familiar with e-mail protocols...

JMLatJolla ( 2018-01-16 18:43:22 +0300 )edit
1

answered 2018-01-16 15:49:06 +0300

jovirkku gravatar image

Email attachments are kept under /home/nemo/Downloads/mail_attachments/ . Unless there is anything valuable there it is easy to delete all folders in that directory to make sure no unwanted attachments would remain.

edit flag offensive delete publish link more
9

answered 2018-01-16 19:57:24 +0300

Pekka Vuorela gravatar image

Actually, I think the issue here likely just got fixed a little time ago there: https://git.merproject.org/mer-core/nemo-qml-plugin-email/merge_requests/18

Attachment downloaded is a different thing from a saved attachment. POP can very well download the attachment as in email data, but it shouldn't save that email data to disk as a separate file. Email application used to have a sort of a, um, feature that it automatically saved the file upon opening an email if it had been fetched from the server. Fixed with above merge request.

edit flag offensive delete publish link more

Comments

Good to hear it is solved after all!

lakutalo ( 2018-01-16 20:01:46 +0300 )edit

so that means, after next update this bug is gone?

Raymaen ( 2018-01-16 20:08:47 +0300 )edit

No, after having implemented that merge request, precisely speaking. :) Thanks Pekka!

lakutalo ( 2018-01-16 20:16:41 +0300 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2018-01-16 14:55:35 +0300

Seen: 459 times

Last updated: Jan 16 '18