Ask / Submit
2

Sailfish X not indexing SDCard formatted with ext4 [answered]

asked 2018-01-19 20:58:32 +0200

ray-ven gravatar image

updated 2018-01-25 11:35:25 +0200

Moo-Crumpus gravatar image

Well, the title just says everything. Tried tracker reset -e and gsettings set org.freedesktop.Tracker.Miner.Files index-removable-devices true without success. According to this thread it works with vfat. Actually i used the same sdcard in my jolla1 without problems. Storing Pics to SD works out of the camera app - they're not shown in gallery though. The user of the sdcard is nemo

Is this a bug or did I mess with my sdcard? I can safe files on the sdcard with user nemo.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by ray-ven
close date 2018-01-26 15:53:06.127839

Comments

2

For me it works. In Xperia X, photos made with camera app are stored in Ext4 formatted card and do appear in gallery.

Ta_das ( 2018-01-20 11:49:38 +0200 )edit

hmm, interesting. Could you tell me who's owner of the card and which rights are given? For me it's nemo:nemo and I think 755 or so

ray-ven ( 2018-01-20 12:24:34 +0200 )edit

I looked for it in file browser app (I lack skills to do it fast on CLI). The owner is nemo, group nemo, permissions are the following: rwxr-xr-x.

Ta_das ( 2018-01-21 11:25:48 +0200 )edit

I have no problem with 128 GB ext4, images and sound are tracked nicely, and are shown in gallery and media player.

Kim ( 2018-01-24 23:21:04 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2018-01-24 14:18:18 +0200

Raymaen gravatar image

For me it looks like a general bugin the OS. There are many theads on TJC about problems with SD-Cards and formats. For example this one: https://together.jolla.com/question/169040/sailfishx-microsd-card-not-detected/?sort=votes&page=1

No official statement from Jolla so far, if there is investigation already going on... well it is not "tracked by Jolla" so i think there are other things with higher priority.

edit flag offensive delete publish link more
0

answered 2018-01-25 11:34:58 +0200

Moo-Crumpus gravatar image

It is no bug in the OS. I run xperia with an ext4 sd card without issues. Use the storage app that is part of the system settings to unmount, format and mount the card.

edit flag offensive delete publish link more

Comments

but it is not recognised by the System... I don't see it.

Raymaen ( 2018-01-25 14:56:36 +0200 )edit

pictures in folders on the sd card are indexed and shown in the gallery, f.e. I take this as a proof of indexing.

Moo-Crumpus ( 2018-01-26 10:50:31 +0200 )edit
1

@Raymaen: If the card isn't detected as inserted, it cannot be indexed.

Some cards aren't detected (as far as I understand it: because of a known timing problem in the kernel), and because this is hardware related you cannot force it to be detected, it requires a kernel update.

I had a well functioning Samsung 128GB ext4 formatted card on my Jolla C, but had to replace it with a SanDisk to get it to work in my X.

Kim ( 2018-01-26 13:58:48 +0200 )edit

I have a Toshiba 128GB FAT (don't have Linux to formate it to ext4 to try out). it is not recognised. So looks like i have to wait for kernel update.

Raymaen ( 2018-01-26 14:08:27 +0200 )edit
2

answered 2018-01-26 15:52:17 +0200

ray-ven gravatar image

Ok that's what happened: I copied my /home/nemo content to my SDCard in J1, afterwards I put it into my Sailfish X It didn't work in Sailfish X. I reformatted the card an put all (almost) stuff back on the card. After chowning my osmand directory everything worked. The Card gets indexed again. Afterwards I saw, that there's a .nomedia file on the card, which got on the card because I copied all my stuff on it. Because I just copied media etc. and left out .nomedia I guess that was the reason.

In all mobilephones some cards (usually big ones) aren't supported. Please check if your card is supported before buying.

I'll mark this as closed, many thanks to your replies! RAy

edit flag offensive delete publish link more

Question tools

Follow
3 followers

Stats

Asked: 2018-01-19 20:58:32 +0200

Seen: 678 times

Last updated: Jan 26 '18