Ask / Submit
4

Exchange sync stops working - any way to reset it (without reseting phone)?

asked 2018-01-23 18:36:52 +0300

MystIsland gravatar image

On my phone (Xperia X, OS 2.1.3.7) o of my email accounts, a work Exchange account has started failing slightly too often (after couple of days, or 1-2 times per week): all other email accounts sync but the Exchange one fails to (keeps trying, eventually fails and shows only the "x hours ago" when it last managed to sync). This has happened before but I believe it has happened more often during the last month or two.

This might be related to times when the phone changes from wlan to mobile data, at least often it feels like it. But turning mobile data, wlan or the account itself in settings, does not make it work, the only way to get the Exchange mail working again seems to be to reset the phone.

Is there a way to reset only the Exchange support to avoid resetting the phone (which otherwise would easily reach tens of days of uptime in my usage) every now and then?

edit retag flag offensive close delete

Comments

I delete the account and then re-create it when this happens ...

(sigh) too many bugs :(

thisisme ( 2018-01-23 20:02:58 +0300 )edit

Same here, an unresponsive Exchange Sync is my only reason why I regularly have to reboot the phone. From my point of view this is the most critical bug in SFOS at the moment, since all the business/office mail runs over the Exchange account. :(

Kao ( 2018-01-23 20:40:39 +0300 )edit

1 Answer

Sort by » oldest newest most voted
4

answered 2018-01-23 22:17:45 +0300

ziellos gravatar image

Use the following command in terminal to restart Exchange synchronization: systemctl --user restart sailfish-eas

edit flag offensive delete publish link more

Comments

Thanks, I will give it a try next time Exchange Sync breaks down.

Btw, is there any way to make this a quick action on the events screen or something like that?

Kao ( 2018-01-24 00:01:03 +0300 )edit

I use ShellEx for this

mattikbk ( 2018-01-24 18:33:24 +0300 )edit

thanks, that worked great!

stef ( 2018-01-26 19:14:52 +0300 )edit

thanks, that worked for me too on xperia x 3.0.0

Dam ( 2018-11-07 23:51:33 +0300 )edit
Login/Signup to Answer

Question tools

Follow
1 follower

Stats

Asked: 2018-01-23 18:36:52 +0300

Seen: 234 times

Last updated: Jan 23 '18