Ask / Submit
2

Roaming doesn't work (can't turn it on) [duplicate]

asked 2018-02-27 00:35:22 +0200

PureTryOut gravatar image

updated 2018-08-14 16:56:35 +0200

Raymaen gravatar image

Roaming has never worked for me since I bought my Jolla Phone somewhere in 2014. It wasn't a problem at first because using data outside of my own country was expensive, but since the summer of last year, I pay no extra cost inside the EU for using data and I'd very much like to make use of that. However, this has as of yet been impossible.

The moment my phone switches to a non-Dutch (I live in the Netherlands) provider, mobile data turns itself off and refuses to go on again. I can click the checkbox all I want, but it just straight up refuses. The icon in the quick menu is even completely disabled. And yes, I have Roaming set to "Always allow". What can I do to finally make use of the internet (non-wifi) outside of my own country?

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by jiit
close date 2018-08-14 13:33:02.627664

Comments

This problem still occurs half a year later. Been to places outside my own country several times again and I have yet to be able to use roaming. I put my sim card in an Android phone just to test, and it works fine there, so it's definitely a SailfishOS specific problem.

Can someone please take a look at this? I feel really uncomfortable not being able to search on the internet when I'm in an unknown country and around an unknown language. I just can't be the only one facing this problem can I?

PureTryOut ( 2018-08-11 21:33:13 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-08-13 12:49:43 +0200

Raymaen gravatar image

It is a duplicate Question fo this one:

https://together.jolla.com/question/177397/xperia-x-roaming-does-not-show-local-operator-and-does-not-show-connection/

edit flag offensive delete publish link more
0

answered 2018-08-11 21:39:09 +0200

duesselschorsch gravatar image

I had a similar effect when my Jolla was set to the wrong APN with my provider o2 Germany - when I'm in Germany the APN setting doesn't really matter, but when roaming, it is important to set the correct APN, otherwise data doesn't work for me.

edit flag offensive delete publish link more

Comments

You mean the access point name specifically? It's set according to the instructions for roaming of my provider, so that shouldn't be the problem. The weird thing in my opinion is that SFOS just disables the button, rather than just flashing it when trying to connect and failing. It just seems the "Roaming: Always allow" option is completely ignored and it disables roaming anyway.

PureTryOut ( 2018-08-11 21:46:54 +0200 )edit

Yes, the access point name. When I set it correctly I usually don't have problems while roaming - at least when I'm using a foreign provider that provides data roaming with my provider.

duesselschorsch ( 2018-08-11 22:26:23 +0200 )edit

Are you sure though that if you have it set incorrectly, SFOS actually disables the internet button? Like in this screenshot https://disroot.org/_matrix/media/v1/download/disroot.org/BZdDGbCAgROifFyLHSqXZxTp

Because yes, I have set it correctly. At least, according to what my provider tells me.

PureTryOut ( 2018-08-11 22:28:23 +0200 )edit

If I remember correctly the button (was greyed out and couldn't be activated when the wrong access point was set, but I haven't tried it for a year or so, didn't have my Jolla with me whan I was abroad.

duesselschorsch ( 2018-08-11 22:36:48 +0200 )edit

Question tools

Follow
1 follower

Stats

Asked: 2018-02-27 00:35:22 +0200

Seen: 235 times

Last updated: Aug 14