Ask / Submit
7

Wire android application does not work anymore

asked 2018-02-28 02:27:58 +0200

bade866o gravatar image

updated 2018-03-04 15:52:30 +0200

The android Wire stopped working for me. The app was trying to connect to internet without success. I uninstalled the application and re-installed it from Aptoide but now I cannot authenticate. I get the message "Something went wrong. Please try to login again." Anybody got same issue?

edit retag flag offensive close delete

Comments

1

Maybe same issue as this one

https://together.jolla.com/question/179953/a1-tv-android-app-no-longer-works-with-214/

which also seems to be a network thing. (Funny though that in the case of A1TV only parts of the app stay offline)

I also have an old app for reading dilbert that now claims the server is unreachable. I'm not sure, though, if in this case it's just the app that's too old. Need to install it on a real Android device.

ossi1967 ( 2018-02-28 09:57:34 +0200 )edit

Wire bug confirmed (Xperia/SailfishX).

To read Dilbert comics, install Daily Comics (https://openrepos.net/content/tardypad/daily-comics)

objectifnul ( 2018-02-28 12:21:31 +0200 )edit

fetch any older version of wire from uptodown.

Moo-Crumpus ( 2018-02-28 12:54:31 +0200 )edit

@Moo-Crumpus: you can actually download older releases from the Wire homepage. Just change the release in the URL.

E.g. https://wire-app.wire.com/android/prod/wire-3.4.382.apk

Note: This APK has a different signature than Playstore!

I think thats preferable to uptodown (I generally don't trust 3rd party markets too much). The version on Aptoide is ancient, by the way.

rozgwi ( 2018-02-28 13:08:37 +0200 )edit

@rozgwi Great tip about downloading apk's direct from Wire. Are the available version numbers the same as the tags on github or do you have another source for them?

I don't see an ancient version on Aptoide, btw. It looks like the same version as on the Google Play Store to me: https://wire-swiss-gmbh-wire.en.aptoide.com/

Anyway, Wire is a problematic app on SFOS: it doesn't work properly or even at all with Alien Dalvik unless you also install Google Play Services (which takes away part of the point of not using Android in the first place). I'm hoping that either the improved Android support for SFOS later this year will help, or maybe someone will write a native SFOS client. (I'd love to write one myself, but don't have the time.) This is a pity: it is the only app of its type that I have found that:

  • is similarly-featured to WhatsApp
  • is palatable to non-techies who are used to WhatsApp
  • has a reasonable stance on privacy.
pakman ( 2018-02-28 18:35:14 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-02-28 13:11:12 +0200

rozgwi gravatar image

updated 2018-02-28 13:13:03 +0200

It seems that part of the the issue is lacking TLS 1.2 support in Alien Dalvik

As suggested in the comments you could try to downgrade.

edit flag offensive delete publish link more

Comments

Downgraded to v3.4.382, v3.6.391 and v3.7.398. All fail.

objectifnul ( 2018-02-28 14:08:42 +0200 )edit

I experienced a problem with wire update from january in playstore. After that wire quits immediately with the message: unfortunately wire has stoppen. I downgraded to version 3-5-388. This version works in my case. The login process is buggy but trying several times and once I got it.

carepack ( 2018-02-28 14:20:47 +0200 )edit

I have tried to downgrade up to 3.1.369 from Aptoide but still did not work.

bade866o ( 2018-02-28 19:04:30 +0200 )edit

Even tried old v2.41.359. Failed.

objectifnul ( 2018-02-28 23:52:15 +0200 )edit

I am running 3.5.388 without any google services on my xperia, with background services enabled.

Moo-Crumpus ( 2018-03-01 10:58:34 +0200 )edit
1

answered 2018-03-04 20:23:49 +0200

pakman gravatar image

updated 2018-03-04 21:06:25 +0200

A couple of people have commented in this topic that downgrading to a previous version of the Wire app is no longer a way of getting it to work. This suggests to me that Wire might have changed something server-side that requires the current version of the app. This means that those of us who were using Wire on Sailfish have reached the end of the line, temporarily at least.

In an ideal world, someone would write a native Sailfish client for Wire, but I think that if anyone was planning to to that, we would have heard about it by now, if not here, then on the Sailfish OS forum of TMO. I also don't hold out any hope that the Wire developers will revert any of the changes that they have made recently that stopped Wire working completely for us: that would involve them putting in extra work to support a partial implementation of an obsolete platform (i.e. Alien Dakvik's support for Android 4.x without Google Play Services). IMHO the best chance of getting Wire functionality back is with this year's work by Jolla on Android support. To give this the best chance of happening we need to make some noise, both with Jolla and Wire. My own efforts so far have been my Wishlist for Android support in 2018 (which was motivated by the Wire problems) and my original TLS issue at GitHub.

I am going to close the github issue and open a new, more general one. Please keep contributing to the discussion, in particular to keeping SailfishOS on Wire's radar: I suspect that they know very little about it, other than what they have heard from me and @jsommer

Edit: here is my new issue on Wire's GitHub repo for the Android app: https://github.com/wireapp/wire-android/issues/1437

edit flag offensive delete publish link more

Comments

I'll gladly upvote your new issue on Github.
Edit: BTW, did you get a chance to take a look at the logs?

rozgwi ( 2018-03-04 20:30:13 +0200 )edit

@rozgwi re the logs: I never managed to figure out how to enable the logs that would contain the required output. 'journalctl' didn't contain anything relevant AFAICS. If you have any hints I'lll try them out.

pakman ( 2018-03-04 21:10:34 +0200 )edit
1

The Wire support confirmed today, that the service requires TLS 1.2. This would be only possible with Android 5 or newer. Alien Dalvik emulates 4.4 - as I know.

jsommer ( 2018-03-05 18:52:31 +0200 )edit

And Wire have confirmed that they are not going to do anything special for Sailfish OS, even in the context of the upgrade in Android support for Sailfish due in 2018. Any improvement in the current situation is down to Jolla's work on Android support being sufficient to support the Wire android app (or a native Wire app being written, but I think that that is unlikely in the near future).

pakman ( 2018-03-05 20:11:28 +0200 )edit

What is the alternative?

I checked Riot, but I was disappointed by the privacy policy. The marketing highlights privacy and security, but the privacy policy describes collection of personal data, even exchanged content: „Information we collect about you … the communication content that you send and receive while using our Service. This may include message content and timing information, including text, photo, video and other media files in the context of the communication history of a room.“

Telegramm and Threema are just text chat messengers and I don’t really trust the first one. Just for text messaging JTox seems to be a good solution, that is available as a native Sailfish app. Unfortunately this app doesn’t support audio and video messaging. I like the technical approach. Maybe, we can encourage the developer to go ahead with financial contribution.

Twinme looks interesting, at least for private use. It includes voice and video chat. But I can’t really rate the credibility. This app is available at the Harbour app. The business model is not clear. That is suspect.

jsommer ( 2018-03-05 22:56:45 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2018-02-28 02:27:58 +0200

Seen: 790 times

Last updated: Mar 04 '18