Ask / Submit
4

light sensor very sensitive lapuanjokii xperia [answered]

asked 2018-03-01 04:08:29 +0200

hagiz gravatar image

updated 2018-12-10 00:03:15 +0200

rozgwi gravatar image

Light sensor seems to have become very sensitive after update. Watching TV in the dark makes the screen light flicker a lot.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by rozgwi
close date 2018-12-10 00:03:26.766824

Comments

3

I can confirm. That in the dark the screen flickers. It is flickering also in Kymijoki.

salarelv ( 2018-03-01 08:05:17 +0200 )edit

This was already present in 2.1.3. It is not a new issue, but it should ve filtered better.

SaimenSays ( 2018-03-01 13:22:23 +0200 )edit

@SaimenSays There is no setting that will suit everybody in every situation. It is always about choosing least bad compromise. And no matter which way things are changed it will be worse for somebody somewhere.

spiiroin ( 2018-03-01 13:25:33 +0200 )edit

To control the sensitivity, Jolla could add some kind of setting (like mode; quick and slower). Furthermore, you could control this by ambiences too.

Sakke ( 2018-03-03 17:54:58 +0200 )edit

1 Answer

Sort by » oldest newest most voted
5

answered 2018-03-01 12:49:02 +0200

spiiroin gravatar image

This "TV in dark room" is about the worst possible scenario you can create for automatic brightness tuning. The changes in lightning can be short lived (should be ignored) or last for long (should be acted on), but there is no clear period / length to filter out.

One must effectively choose between reaction time (to real ambient lightning changes like walking out to sunshine, turning on the lights, etc) and stability (in noisy surroundings like this TV in darkness, sitting in a bus driving past street lamps, etc).

You can tweak the filtering parameters from command line - the defaults are:

mcetool --set-als-sample-time=125 --set-brightness-fade-als=1000

To favor stability, you can try something like:

mcetool --set-als-sample-time=500 --set-brightness-fade-als=5000

(Changes are ignored for roughly 4 seconds, and actual fading is done much more subtle speed)

edit flag offensive delete publish link more

Question tools

Follow
4 followers

Stats

Asked: 2018-03-01 04:08:29 +0200

Seen: 195 times

Last updated: Mar 01 '18