Ask / Submit
13

[Xperia X] [bug] [2.1.4.14]Notificationsound through speakers while listening to music via earphones [Released in 2.2.0.29]

asked 2018-03-06 19:11:35 +0200

Raymaen gravatar image

updated 2018-07-04 18:57:51 +0200

While earphones are pluged in for music the messagenotificationsound (of threema app) apears through the speakers and not through earphones. Also a piece of the musik is comming out as well. After the notificationsound the music is again coming through earphones. Musikplayer is a native one. Somebody experienced this issue as well?

It is annoying when the notificationsound comes out together with pieces of musik, when I'm traveling every day by train to work.

It shoud be fixed if its a bug.

If that is a feature, then there schould be a possibility to selecting the option you want to use.

Workarounds schould not be the usual way to deal with such things, if Sailfish OS wants to be mainstream someday.

edit retag flag offensive close delete

Comments

Yes, not sure everyone considers it a bug though. ;) My family hated having the notification sounds in the music connected to central speaker system. Most of the time the non-notification sound is still on in the earphones while notification is sounding outside though. The latter increses the risk of missing notification/alarm when on earphones so personally I prefer the previous behavior with the mixed sounds.

ljo ( 2018-03-06 19:30:56 +0200 )edit
1

To clarify what happens here: Playing music on headphones -> music stop -> notification sound through speaker (with pieces of music) -> music continues on headphones. The music should not stop playing and the notification should play through the speaker. It could be a configurable in Ambiences (there should be way more settings with ambiences). (I had no Idea how to test it, so I used notificationtool -o add -T 10000 -c x-nemo.messaging.im "test notification" to spawn a notification with sound)

Hangman ( 2018-03-07 21:22:06 +0200 )edit
1

Confirmed for Jolla 1 on Sailfish OS 2.1.4.14.

zackbuffo ( 2018-03-12 15:23:35 +0200 )edit
1

I can confirm this also. It's little bit annoying when everybody else hears my notifications with one second of music. Hopefully this will be fixed soon. I believe it will be easy to fix..

Jk ( 2018-04-05 23:03:13 +0200 )edit
2

I find it annoying when even being muted, the phone just gives notification sound while listening to music. There's a reason when I don't want to hear any notification ringtones etc. :D. In my opinion only alarms should work in this way.

Sakke ( 2018-04-06 20:20:13 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-03-06 19:54:36 +0200

Stedephys gravatar image

messing arround with

/usr/share/ngfd/events.d/<the config file that seams to have something to do with the notification sound>

may help. though changing

sound.stream.media.name

didn't work for me, there may be some other combination of tweaks that may result in the sound you want to be played over the headphones being handled like another category of sound that does work the way you want to. it may also help to run the app that produces the sound as root(this is meant in combination with tweaks in the config files).

edit flag offensive delete publish link more
0

answered 2018-07-04 18:57:11 +0200

Raymaen gravatar image

updated 2018-07-04 18:58:14 +0200

This bug got solved with the last update to 2.2.0.29!

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2018-03-06 19:11:35 +0200

Seen: 632 times

Last updated: Jul 04 '18