Ask / Submit
5

Open link bug 2.1.4.14 [answered]

asked 2018-03-09 22:28:01 +0200

rfa gravatar image

updated 2018-03-15 09:41:15 +0200

When I click on a tweet in events view it gives me the option of which browser I want to open the tweet (Great!)

But all it does is open that browser - not the tweet

Expected behaviour is that it would open my twitter client (if installed) or if only a browser was able to be used, open the tweet in the (selected) browser - not just the browser.

What am I doing wrong?

Using Xperia X

Edit 20180314 - changed title to match

It's worse than originally thought;

I can't open any links in the default email client either. I've been using outlook, which will open links in Firefox. Using Twitter (Android version) I can open in the Twitter browser. Using either Pingviini or Piepmatz I can't open any links.

So, now, whether I get a link in email, try to open a tweet or do anything other than click on a link in an already open browser nothing happens (default mail client & SailfishOS Twitter clients)

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by rfa
close date 2018-04-01 08:18:40.296854

Comments

1

In my case, the browser shows the tweet. Difference seems to be that only 1 browser is installed, so there's no question which one to use either.

ossi1967 ( 2018-03-11 23:27:35 +0200 )edit
3

If the default browser is defined as sailfish browser or webpirate, it works. If it is defined as firefox (andoird), it doesn't. The same problem has been found for links in email messages.

phklrz ( 2018-03-14 12:55:28 +0200 )edit
1

@phklrz how do you change the default (browser)?

Even with Twitter installed (from "Store") it gives me the option of using Twitter to open (event view) linbks, but nothing opens...

I can't verify my email anymore

rfa ( 2018-03-14 13:01:32 +0200 )edit
1

@rfa officially there is no way of doing that. There is an unofficial way set the browser in the open-url.desktop file you can find in /usr/share/applications. The default looks like this:

[Desktop Entry]
Type=Application
Name=Browser
NoDisplay=true
X-MeeGo-Logical-Id=sailfish-browser-ap-name
X-MeeGo-Translation-Catalog=sailfish-browser
MimeType=text/html;x-maemo-urischeme/http;x-maemo-urischeme/https;
X-Maemo-Service=org.sailfishos.browser.ui
X-Maemo-Object-Path=/ui
X-Maemo-Method=org.sailfishos.browser.ui.openUrl
leszek ( 2018-03-14 16:01:23 +0200 )edit
1

Do you have "private navigation" enabled ? I have the same issue since a few days using the default browser and I just realized that switching to "normal navigation" makes it work again :

Dam ( 2018-03-14 18:20:51 +0200 )edit

1 Answer

Sort by » oldest newest most voted
-1

answered 2018-03-17 02:49:31 +0200

rfa gravatar image

the Twitter link opening bug fixed

I needed to (re) launch & (re) set my default apps using Mimer - from storeman - by llelectronics

Now, when I click on a link in events feed it opens in my (set in Mimer) default browser (but no longer in Twitter)

I still can't open links in SailfishOS email...

edit flag offensive delete publish link more

Comments

Now i can open links in individual SailfishOS apps, just not SailfishOS email

rfa ( 2018-03-17 03:56:01 +0200 )edit

Question tools

Follow
4 followers

Stats

Asked: 2018-03-09 22:28:01 +0200

Seen: 350 times

Last updated: Mar 17 '18