Ask / Submit
22

BT audio stuttering when WLAN enabled [duplicate]

asked 2018-03-12 10:51:54 +0300

Nrde gravatar image

updated 2018-09-19 11:38:13 +0300

As this was closed without giving a link to the duplicate issue I'll add it here: https://together.jolla.com/question/170354/bluetooth-audiostream-is-choppy-when-wlan-is-on/

this issue has been mentioned elsewhere in comments but I can't see that much activity and people are less active on commenting on them. I don't know if Jolla is tracking this issue so opening an issue.

BT audio/music being unusable if wlan is enabled. As soon as wlan is disabled the audio works more or less without issues.

Comments I've seen suggest over-agressive wlan search when no known wlan is in the range.

I have heard the light symptoms since Jolla 1, Jolla C (very occasional stutter) and now with Sailfish X, BT audio is plain unusable. When wlan is on and I leave the house, be in the car etc. where wlan is not available the audio keeps stuttering every 1-5 seconds.

Update: with the latest 2.2.0.29 bluetooth has gotten even worse if possible.

  • connection to my car BT does not work reliably, deleting pairing and re-pairing works until the next time, before it connected automatically, except rare instances when I had to either turn the radio on of, or switch BT on/off on the phone.

  • before I could use "car set", but now it's not audible anymore although shows as "connected". To get sound from the phone (like music, podcast) "loudspeaker" type needs to be used. Obviously I haven't tested calling as it's not audible when car type is selected.

So all in all, BT support is getting worse.

Another update:

Automatic connection seems to kind of connect to car radio but without audio. Opening phone setting-> bluetooth and then connecting makes the audio work. Same stuttering as before when wlan is enabled though.

edit retag flag offensive reopen delete

The question has been closed for the following reason "duplicate question" by jiit
close date 2018-09-12 15:25:10.060400

Comments

I am not sure WLAN is the problem, I have a similar stuttering experience with using two Nokia 360 speakers (left, right), it usually helps when I disconnect and connect again. Also I have a different issue with car stereo (Navi 600), hands free profile, which disconnects after a couple of minutes.

pmelas ( 2018-03-12 12:10:42 +0300 )edit
3

I can reliably (100%) get rid of the stutter if I turn off wifi in settings. Note that the stutter happens reliably when the phone doesn't see known wlans. It happens a lot less when there's wlan available, although when it's weak (like it is in my office for example) I hear some occasional stutter.

I have tested it with Nokia BH-111 BT dongle, at home using logitech BT recevier and JVC car stereo (Parrot unit of some kind?), where I notice the stutter every time.

Nrde ( 2018-03-12 13:37:34 +0300 )edit

my xperia bluetooth connection also stuttering when moving and from distance more than 40 cm

meldolion ( 2018-03-13 22:44:57 +0300 )edit

What channel does the wifi use when the problem occurs?

vattuvarg ( 2018-06-03 20:49:43 +0300 )edit

Is there a way to know? For me the problem is when the wlan is on in the phone, but there is no connection. I.e., wifi is out of range.

Nrde ( 2018-06-03 23:06:10 +0300 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2018-06-03 09:05:09 +0300

kristian80 gravatar image

I got this problem too. Fixed when i disabled wlan.

edit flag offensive delete publish link more
2

answered 2018-06-03 12:00:37 +0300

fridl gravatar image

updated 2018-06-03 18:06:52 +0300

I have the Problem, too. But it does not help to deactivate WLAN.

EDIT: Can i somehow find out, which codec is used with the BT device and can i forbid some codecs manually? It seems, that not all codecs have massive issues...

edit flag offensive delete publish link more

Comments

Same problem here. Very annoying bug.

louisbob ( 2018-06-03 19:32:58 +0300 )edit

What about aptx codec? does it work?

bennypr0fane ( 2018-07-13 14:57:38 +0300 )edit

Some people does not have the stuttering issue anymore with the latest 2.2.1.18. Can anyone confirm this?

louisbob ( 2018-09-19 10:02:06 +0300 )edit
1

answered 2018-09-11 09:14:21 +0300

Olsen gravatar image

In my setup (Xperia X, SFOS 2.2.0.29), stuttering completely disappeared since I switched to a 5 GHz wlan. No stuttering even while running an ISP speedtest on the phone in parallel.

edit flag offensive delete publish link more

Comments

How can I change my wlan to use 5GHz. As I'm using it at home (where I can modify my router), at work, at the university, EDUroam, airports etc.

Nrde ( 2018-09-11 10:20:28 +0300 )edit
2

The fundamental reason for the interference should be that both Bluetooth and WLAN (the usual 2 GHz channels) conflict at the 2.4 GHz frequency band. If stuttering disappeared by making WLAN use the 5 GHz band, this suggests that the assumed reason is probably correct.

jovirkku ( 2018-09-11 10:23:26 +0300 )edit
1

But what would be the reason that it works with Jolla 1 and C, or the stuttering is much less obvious, i.e., BT is usable when WLAN is enabled. On my devices BT with WLAN is unusable only with Sailfish X.

Nrde ( 2018-09-11 10:33:30 +0300 )edit
1

Ok, nice workaround. But only switching of wlan completely seems to do the trick for me. On 5GHz i still get occasional stutter. but much less than before.

mosen ( 2018-09-11 11:52:12 +0300 )edit

Question tools

Follow
11 followers

Stats

Asked: 2018-03-12 10:51:54 +0300

Seen: 516 times

Last updated: 2 days ago