Ask / Submit

HSL ticket app

asked 2018-03-13 17:58:30 +0200

DiBasse gravatar image

I want to share this: if you need a Helsinki area bus ticket you can download the app directly from here

The latest version requires Android 5.0 or newer and does not work on my Xperia X. But the oldest version did work! No I did not try all the versions.

edit retag flag offensive close delete


Thank you. Just download versio to my J1

Spedeshow ( 2018-03-13 20:53:36 +0200 )edit

Its a shame that the app is not GPL.

tortoisedoc ( 2018-03-13 23:22:25 +0200 )edit

I have the latest beta ( version from play store (using Yalp store) and it works just fine on my Xperia X. Android 5+ is needed for credit card payment but the mobile payment does work with 4.x.

Jolla did say that sailfish v3 would get some updated version of the android support, haven't said what/how yet

ahjolinna ( 2018-03-14 10:09:37 +0200 )edit

@tortoisedoc, yes.

If the API was open I'd build me native version. As it is now, it's no use to me.

juiceme ( 2018-03-14 20:24:28 +0200 )edit

@juiceme the API is open? There's even harbour-jollaopas ?

tortoisedoc ( 2018-03-14 20:35:33 +0200 )edit

2 Answers

Sort by » oldest newest most voted

answered 2018-03-14 08:53:36 +0200

DiBasse gravatar image

The needs Android 5.0 or later and hence does not work. the works at least.

edit flag offensive delete publish link more


Weird. I test it yesterday this versio in my J1 and buy a ticket with no problems.

Spedeshow ( 2018-03-14 09:40:50 +0200 )edit

Did you pay with credit card?

DiBasse ( 2018-03-14 13:33:32 +0200 )edit

answered 2018-03-14 19:24:24 +0200

goldenm gravatar image

updated 2018-03-14 19:26:21 +0200

There are two different apks with the same version number: March 8, 2018 - Does not work with Jolla, requires Android 5 Feb. 4, 2018 - Does work with Jolla (Sailfish X), I used credit card payment and everything went smoothly.

I also tested latest 2.2.x.x version, it opens but wasn't compatible with HSL anymore (buying a ticket was impossible). --> Check previous versions

edit flag offensive delete publish link more


Do you have googplayservices or microg installed ? None of the 2.3.1 versions would not work for me.

beeki ( 2018-03-14 20:55:31 +0200 )edit

Yes I have google play services installed, not sure if this app requires it.

goldenm ( 2018-03-14 22:57:06 +0200 )edit
Login/Signup to Answer

Question tools



Asked: 2018-03-13 17:58:30 +0200

Seen: 268 times

Last updated: Mar 14