Ask / Submit
1

No cellular / mobile cata connection - Error: Unexpected data call status 33 [answered]

asked 2018-03-16 02:41:22 +0300

jollabit gravatar image

I've done a clean install of Sailfish OS on my Intex Aqua Fish. At home, everything seemed fine, then I've left home and realized, I do not have mobile data connection. Back home, I've checked "Settings" - "Cellular network". There appears a flickering message changing between "Enabled" and "Connecting", changing every ~0.5 seconds. When debugging the phone with

systemctl status -l ofono.service

I'm getting this repeating output:

...
Mar 16 00:39:10 Sailfish ofonod[18237]: Activating context: 1
Mar 16 00:39:10 Sailfish ofonod[18237]: Unexpected data call status 33
Mar 16 00:39:11 Sailfish ofonod[18237]: Activating context: 1
Mar 16 00:39:11 Sailfish ofonod[18237]: Unexpected data call status 33
Mar 16 00:39:11 Sailfish ofonod[18237]: Activating context: 1
Mar 16 00:39:11 Sailfish ofonod[18237]: Unexpected data call status 33
Mar 16 00:39:12 Sailfish ofonod[18237]: Activating context: 1
...

I've installed the App "Ofono Log" from the Jolla App Store, which shows this additional information:

2018-03-15 23:16:39.752 drivers/ril/ril_data.c: ril_data_call_list_parse() version=11,num=1
2018-03-15 23:16:39.752 drivers/ril/ril_data.c: ril_data_call_list_parse() [status=33,retry=-1,cid=0,active=0,type=(null),ifname=,mtu=0,address=(null), dns=(null) ,gateways=(null)]
2018-03-15 23:16:39.753 Unexpected data call status 33
2018-03-15 23:16:39.754 src/gprs.c: pri_activate_callback() 0x1e32cd0
2018-03-15 23:16:39.756 src/gprs.c: pri_activate_callback() Activating context failed with error: Unknown error
2018-03-15 23:16:39.758 drivers/ril/ril_radio.c: ril_radio_power_off() RIL2 0x1e22e90
2018-03-15 23:16:40.128 Activating context: 1
2018-03-15 23:16:40.128 drivers/ril/ril_data.c: ril_data_request_queue() ril_1 queued CALL_SETUP request 0x1e35230
2018-03-15 23:16:40.128 drivers/ril/ril_radio.c: ril_radio_power_on() RIL2 0x1e22e90

If I switch to 3G, the flickering message disappears, but I still don't get a working Internet connection, the same when I switch to 2G.

Can somebody help me with a trick to make the mobile data connection working?

I've tried already:

  • Rebuilt the folder content: /var/lib/ofono
  • Searched for a repair function within the App "Ofono Log", but there is no such option
  • Reboot (many times)
  • Turned Airplane Mode off and on (many times)
  • Made Phone calls and called the phone to see if something changes
  • Read dozens of forum posts in this forum

My situation:

  • I have only one single SIM-Card
  • The Phone is new (Intex Aqua Fish)
  • Sailfish OS Version Lapuanjoki, V 2.1.4.14
  • I did wheter change nor mess the system
  • All the installed apps are from the integrated Jolla Store and Android Store
  • I do not have any critical or suspicious App installed

Thank you very much for your help! I love this phone and i'm looking forward to get it working :-)

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Edz
close date 2018-04-13 23:34:51.324238

Comments

1

I've experienced this once with my Jolla1 (2.1.4.14) and like you, I tried all sorts of different things, but in the end, turning the device off and back on sorted the problem for me.

Edz ( 2018-03-18 14:56:43 +0300 )edit
1

Unfortunately, turning the phone off and on did not solve the problem in my case :-(

jollabit ( 2018-03-18 15:07:26 +0300 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2018-04-12 22:32:52 +0300

jollabit gravatar image

I've found the solution:

My Telecomprovider is Salt in Switzerland. I had to enter the APN-Name to "Salt Internet" and the APN-Connection to "internet". That did the job!

image description

edit flag offensive delete publish link more

Question tools

Follow
1 follower

Stats

Asked: 2018-03-16 02:41:22 +0300

Seen: 216 times

Last updated: Apr 12