unable to install qt5-qtconnectivity-qtbluetooth [answered]

asked 2018-03-20 23:09:34 +0200

Kim gravatar image

updated 2018-03-20 23:17:42 +0200

Hi

I'm working on a small app using bluetooth to communicate, it compiles on latest SDK without problems, but when I try to install on my Xperia (with latest update) it insists that the install requires qt5-qtconnectivity-qtbluetooth-5.6.2+git0-1.4.2.armv7hl to be installed, something I find perplexing as bluetooth is installed and are functioning.

When I allow the install, I get the following errors:

Download (curl) error for: https://releases.jolla.com/releases/2.1.4.14/jolla/armv7hl/qt/armv7hl/qt5-qtconnectivity-qtbluetooth-5.6.2+git0-1.4.2.armv7hl.rpm

Error code: Connection failed

Error message: Could not resolve host

releases.jolla.com

I have tried to enter the url in a browser, and get a 404.

Any ideas?

Edit: I have tested on my Jolla C, with latest upgrade, and the problem is there also.

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Kim
close date 2018-03-21 01:31:44.411578

Comments

pkcon search name qt5-qtconnectivity-qtbluetooth

pkcon install qt5-qtconnectivity-qtbluetooth

objectifnul ( 2018-03-20 23:36:47 +0200 )edit

No, the search tells me the package is available, but the install fails

I found that I generally had problems with my Internet, that was solved by a reset of the router.

Now I get the following error:

Fatal error: File'./qt/armv7hl/qt5-qtconnectivity-qtbluetooth-5.6.2+git0-1.4.2.arm7hl.rpm' not found on medium 'https://releases.jolla.com/releases/2.1.4.14/jolla/armv7hl/'

Kim ( 2018-03-21 00:04:13 +0200 )edit

Already tried a pkcon refresh?

Alex ( 2018-03-21 00:29:24 +0200 )edit

Yes, didn't solve the problem.

But a reboot did.

Thanks for your help.

Kim ( 2018-03-21 01:31:23 +0200 )edit