Ask / Submit
17

[SailfishX] recorded audio volume low

asked 2018-04-04 00:33:28 +0300

h.berd gravatar image

updated 2018-09-01 15:35:48 +0300

Hey,

the volume for audio messages in the android telegram app and in the native camera video app is too low for me. Sometimes I speak directly in the microphone to record an audio message in telegram and the receiver can't understand it. I also had done some videos, where the recorded volume could be much higher. For example, if somebody is speaking 2m away you can't understand anything on a other phone except SaifishX. On SailfishX I have the 'too loud' bug to understand all these low volume recordings, but on a Iphone this doesn't work for example.

Can I change the volume for recordings anywhere and will it effect the volume of the telegram audio messages?

Thanks and all the best!

edit retag flag offensive close delete

Comments

confirm, volume is to low :(

cvp ( 2018-04-04 14:32:44 +0300 )edit

also audio.recorder.on xperiax is ...

pawel ( 2018-04-05 07:05:24 +0300 )edit

I can confirm this bug, with both WhatsApp voice messages, and the native "Recorder" app from Jolla Store. I'll post this to the SailfishX bug thread too.

txus ( 2018-08-31 18:18:21 +0300 )edit

I have that bug too. People on the phone with me complain about the internal microphones volume. They can barely understand me.

A samsung headsets volume is much higher than the internal microphones.

So it seems not to be a general audio input problem but one of the internal microphone.

Nuke33 ( 2018-09-18 16:12:17 +0300 )edit

Same with Threema voice messages (and Recorder-App too). No problems with the volume when talking on the phone.

horschi ( 2018-09-21 23:37:21 +0300 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2019-03-13 01:18:33 +0300

hammerhead gravatar image

As outlined by user @Edz in an answer, the microphone volume can be adjusted using pacmd:

# Set recording volume to 250%
pacmd set-source-volume source.primary 163840

(I doubt that normal phone calls go through PulseAudio, so this should not affect those.)

You can verify the new setting is active by commanding the following:

# Show details about the second audio source
pacmd list-sources | grep -A11 'index: 2'

The question is how to persist the setting across reboots. The following configuration (source), for example, has no effect:

# This should persist the setting across reboots, but DOES NOT
echo -e '.include /etc/pulse/default.pa
set-source-volume source.primary 163840' > ~/.config/pulse/default.pa

Providing the settings in /etc/pulse/default.pa also fails.

Maybe some other user has a solution to this (?)

edit flag offensive delete publish link more

Comments

For those interested: If you add the command to the ~/.bashrc file, you "only" need to start the Terminal app once upon reboot in order to set the volume (echo 'pacmd set-source-volume source.primary 163840' >> ~/.bashrc). That's just a workaround until a clean solution is found.

hammerhead ( 2019-03-13 01:31:08 +0300 )edit

@hammerhead:
htop shows me that pulseaudio is being run with the parameters
-n --file=/etc/pulse/arm_droid_default.pa

The man page of PA states that -ndisables loading default.pa from both home and the /etc system path.

Thus, editing the custom 'droid' config directly is necessary.
Following the advice not to directly change global Pulse config files from the ARCH wiki I created a user configuration at ~/.config/pulse and sourced it in the droid one like this:

### Load local config from Nemo
.ifexists /home/nemo/.config/pulse/custom-rec-volume.pa
 .include /home/nemo/.config/pulse/custom-rec-volume.pa
.endif

pacmd list-sources displays the volume of source.primary as 131072 after rebooting

rozgwi ( 2019-03-28 23:02:39 +0300 )edit

As @mrtrm noted in the other question, it might be interesting to investigate unwanted side effects to the record volume while calling

rozgwi ( 2019-03-28 23:09:44 +0300 )edit
0

answered 2018-09-02 08:43:03 +0300

luxbrux gravatar image

confirm bug...

edit flag offensive delete publish link more

Comments

This is not an answer, please try and avoid using answer boxes for commenting, thanks.

Edz ( 2018-11-25 12:58:38 +0300 )edit
Login/Signup to Answer

Question tools

Follow
8 followers

Stats

Asked: 2018-04-04 00:33:28 +0300

Seen: 497 times

Last updated: Mar 13