We have moved to a new Sailfish OS Forum. Please start new discussions there.

SailfishX can't handle 2 WLAN APs ("slow" roaming)?

asked 2018-04-09 11:39:21 +0300

Sunny gravatar image

updated 2018-04-10 15:05:47 +0300

jiit gravatar image

I'm not asking about 802.11r (fast roaming), but normal re-association to another AP. JP1 never had a problem, but SailfishX loses connection if I'm in AP2-range, as soon as AP1 is out of range. Seems it still want's to connect to AP1... :-( A dozend other clients - including JP1- don't have problems, so we can assume AP infrastructure is working fine here (inclugin 802.11r).

5GHz doesn't work at all :-(

Thanks for any bux-fix-intention notifications.

edit retag flag offensive close delete

1 Answer

Sort by » oldest newest most voted

answered 2018-04-10 14:03:15 +0300

Pasko gravatar image

updated 2018-04-10 14:06:04 +0300


AFAIK every AP has a different MAC address even if they use the same AP name (BSSID).

Do AP1 and AP2 have the same BSSID name? If so, try the next steps:

Provided AP1 works for you and AP2 doesn't:

1.- Move to the AP2 coverage area wih your device.

2.- Turn your device's WiFi off.

3.- Tap in the option "Connect to Internet" and then "Turn WLAN ON"

4.- You should now have AP2 in the list of available AP's. Tap on it and enter your authentication data.

After this step you should have both MAC addresses stored in your device.

Also keep in mind that it is always the device's duty to determine the moment to switch from one AP to the other and the lower level of signal that triggers a network scan is different in different devices...

Regarding the 5Ghz not working... can you elaborate a bit more on this?. I haven't had any issues with this band...


edit flag offensive delete publish link more
Login/Signup to Answer

Question tools



Asked: 2018-04-09 11:39:21 +0300

Seen: 209 times

Last updated: Apr 09 '18