Ask / Submit
1

nextcloud Cal/CardDAV-sync with device-password [answered]

asked 2018-04-18 18:47:35 +0300

Hades0299 gravatar image

Hello,

I'm using a self-hosted Nextcloud-instance for my calendar and contacts and want to configure it for more security with 2-Factor-authentication. As that is not supported by syncclients, i wanted to use device-passwords as described here.

As far as I have tested it, I get the information that 'An account needs updates' (or similar, not using English UI) and a bunch of Login-failed messages in the Nextcloud-logs.

Sync works with 2-Factor-Authentication disabled, and I'm sure I have the correct Device-password.

If necessary I will provide Logs via email.

Regards Hades0299

edit retag flag offensive reopen delete

The question has been closed for the following reason "the question is answered, an answer was accepted" by Hades0299
close date 2018-04-18 23:19:56.221132

Comments

Not an answer but 'works for me' comment:
I actually have DAV sync to Nextcloud with active OTP working.
All I did was creating an App password in Settings > Security.
Providing that in SailfishOS's DAV account settings worked for me. I'm using SailfishX 2.1.14.

rozgwi ( 2018-04-18 21:00:34 +0300 )edit

interesting, exactly that is not working for me :/

Eventually my Nextcloud has a Problem than, will look into that. Which Nextcloud version do you have? 13.0.1?

Also I'm on Sailfish OS 2.1.4.14.

Hades0299 ( 2018-04-18 21:06:50 +0300 )edit

It's the most recent Nextcloud, something like 13.x ( I'm not the admin ).
Maybe I'm wrong but I think I had some issues getting the correct DAV URL the first time... Don't know how to check that for an existing account...

rozgwi ( 2018-04-18 21:20:08 +0300 )edit

As long as you aren't on a beta or a daily build, we have the same Nextcloud version.

Had some Problems with the url as well, but got it working. I have no idea of how too check the url, except by looking into the verbose logs. Maybe there is an easier way, but i don't know that.

Hades0299 ( 2018-04-18 21:26:13 +0300 )edit

I've been having a problem with it recently also,but was having the problem before i updated my nextcloud to use 2FA and an app password for the carddav account on sailfish. Every 1-2 days i will get a notification that "Account needs to be updated".

This is especially annoying using the App password, because i can't get Sailfish to copy and paste from my nextcloud settings. (Nextcloud website instructs me to Ctrl-C to copy)

edit: sync works when i add the password back in, but only for a day or 2. I have the contacts synced with rainloop also, but don't have any issues there.

saba- ( 2018-04-27 07:47:43 +0300 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2018-04-18 21:45:50 +0300

Hades0299 gravatar image

updated 2018-04-18 23:17:44 +0300

ok, creating a new Account in the sailfish-settings helped....

could it be, that capitalization be a Problem? In the working account i wrote my username beginning with a lowercase, and on the nonworking one i used a capital. AFAIK it doesn't make a difference on the webinterface. Also with the working account i had added a '/' at the end of the URL ('https://correct.tld/remote.php/dav/')

The data is stored in a sqlitedatabase in ~/.config/libaccounts-glib/accounts.db. Feel free to use this information, but be warned, that reading or writing this database can have unintended sideeffects.

edit flag offensive delete publish link more

Comments

Very interesting. I'd wager that PHP somehow resolves different cases in the user name.
But when connecting to the DAV directory over HTTP directly it might be relevant. At least this is the case on any unix based server setups.

Thanks for the location of the accounts DB, it might come in handy.

rozgwi ( 2018-04-18 23:34:45 +0300 )edit

Question tools

Follow
3 followers

Stats

Asked: 2018-04-18 18:47:35 +0300

Seen: 288 times

Last updated: Apr 18 '18