Ask / Submit
0

Unable to add some repositories in storeman

asked 2018-04-30 11:39:53 +0200

Spark gravatar image

updated 2018-06-11 23:19:36 +0200

nthn gravatar image

After just reflashing my Xperia to Android and back to Sailfish 2.1.4.14, i am unable to add any repository in storeman. I activated "Allow untrusted software" and storeman sees all apps from openrepos, but when I want to install an app, the field "add repository" is greyed out. Anything I am overseeing?

edit: It seems to be an issue with version 0.0.22 of storeman. The 0.0.21 works as supposed.

edit2: it was NOT a version issue, some repositories seem not to be available, e.g. coderus', while others work.

edit retag flag offensive close delete

Comments

1

Which version of storeman are you using? Make sure to use the latest available.

bomo ( 2018-04-30 12:00:04 +0200 )edit
1

It is the latest available (0.0.22).

edit: seems to be an issue with that version. The 0.0.21 works.

Spark ( 2018-04-30 12:16:52 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-05-01 00:44:24 +0200

Spark gravatar image

It's working again after one day.

edit flag offensive delete publish link more
0

answered 2018-06-11 21:47:40 +0200

marsch gravatar image

I wouldn't call "It's working again after one day" a problem solution, therefore I reopened the question.

The issue seems to persist, also with later versions. I run 0.0.27-1 now and had the same behaviour with the previous version as well:

Storeman works fine with respect to searching etc., but fails in adding a repository. The "Add repository" menu entry is simply greyed out with uninstalled packages, while "Launch" can be selected with every package (even if not installed, of course not resulting in anything).

This kind of looks like a logic glitch, where "Launch" should be enabled, if the package is installed, while "Add repository" should be selectable when the package is not installed. However, it's the other way round.

edit flag offensive delete publish link more

Comments

Same problem here with v.0.0.21

droid001 ( 2018-10-11 23:06:29 +0200 )edit
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2018-04-30 11:39:53 +0200

Seen: 426 times

Last updated: Jun 11 '18