Only the last entry in Call History per contact is displayed

asked 2018-05-24 13:44:48 +0200

jimjamz gravatar image

updated 2018-05-24 13:45:49 +0200

Based on an already raised topic, this was labelled as released. However, this fix is not apparent in Sailfish X. Only the last call entry is displayed in the Call History list for each contact.

Scenario:  Call history displays all call entries
  Given Bob calls Ted on 01/05/2018 at 08:30
  And Ted calls Bob on 01/05/2018 at 10:00
  And Bob calls Ted on 02/05/2018 at 15:15
  When Bob selects the Phone Call History
  Then Bob should see the entries:
    | Ted     | Outgoing  | 01/05/2018 | 08:30 |
    | Ted     | Incoming  | 01/05/2018 | 10:00 |
    | Ted     | Outgoing  | 02/05/2018 | 15:15 |

  BUG: But Bob can see the entries:
    | Ted     | Outgoing  | 02/05/2018 | 15:15 |

The original topic loosely covers the issue, and that also seems to still be pending a fix. There is also this covering the same issue yet none of them seem to have been addressed. If a fix has been released for this issue, then it is surely a regression as Sailfish OS 2.1.4.14 does not exhibit such a fix. The original topics don't relate to a fix being made for Xperia, so I raised this.

edit retag flag offensive close delete

Comments

It was probably mistakenly marked as resolved and can be reopened if need be, although you can still see all of your contact history for each contact separately if that's what you're looking for: tap on a call in the list, then scroll down and tap on 'Activity', and then you get a long list with every call and message you've ever exchanged with that contact. You can also find this history via the People application, or via the contact's details in Messages.

nthn ( 2018-05-24 16:21:33 +0200 )edit
1

tapping on a call in the history calls that contact again. What you're referring to is long press on the contact -> select Open Contact Card -> select Activity from the contact page. So what to do if the number calling is not a saved contact?

jimjamz ( 2018-05-24 17:55:05 +0200 )edit

Ah, I forgot about the quick call option (Settings -> Apps -> Phone), I have it disabled but I'm not sure what the default behaviour is. You're right, though, it doesn't work for people not in your contacts (you can tap on 'Activity', but it's always empty).

nthn ( 2018-05-25 13:18:34 +0200 )edit