Ask / Submit
4

ring from phone with bluetooth device

asked 2018-05-26 20:24:58 +0300

emchella gravatar image

updated 2018-05-28 14:53:20 +0300

jiit gravatar image

With auricular bluetooth, when i have a in incoming call, i desire the possibility , that the ringing play in the mobile , not in the bluetooth device.

How can fix this?

i believe can be usefull a setting chois .

Enrico

edit retag flag offensive close delete

Comments

duplicate?

rgrnetalk ( 2018-05-26 22:23:04 +0300 )edit

BTW, this is default behavior in N9

deloptes ( 2018-05-26 22:57:42 +0300 )edit

My opinion;

@rgrnetalk - the question you've linked to pertains to a potential bug but is not a feature request.

@emchella - please refrain from using the answer box to pass a comment to another user, your 'answer' is not an answer at all, it is merely a response to another comment, so please use comments box for comments.

Edz ( 2018-05-27 12:42:52 +0300 )edit

I can see the reasoning for that; "If a BT headset is connected all audio alerts should be routed there"

However it would be good to have the possibility of defining additional output for alerts in config; for example just yesterday it happened to me that I was listening to Cutespot with BT headset, then paused the music while taking earplugs out to talk to a person nearby. At that time I got an incoming call and did not notice it due to no ringtone on the device itself...

juiceme ( 2018-05-29 16:11:32 +0300 )edit

This was default behavior in Nokia N9. Unfortunately bluez5 is so unfriendly to my car, that I can not use this feature with Sailfish, but I just read this article once again after reading it couple of years ago http://www.lightofdawn.org/blog/?viewDetailed=00031

Are you sure you have HFT profile connected and not A2DP. I think if you had HFT it should work that way, but this is just a good guess. Often A2DP is selected automatically and you can hardly make the difference unless something like this happens as the voice in A2DP is going via the phone, but as it is close to you anyway there is impact only on the quality.

deloptes ( 2018-05-30 00:30:14 +0300 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2018-05-27 11:36:23 +0300

emchella gravatar image

@rgrnetalk i'm sorry, for duplicate question; i have looked look about, but without finding nothing of similar.

anyway i believe can be usefull a setting chois and for the moment i must find a solution.

Enrico

edit flag offensive delete publish link more

Comments

Are you sure you have HFT profile connected and not A2DP. I think if you had HFT it should work that way, but this is just a good guess. Often A2DP is selected automatically and you can hardly make the difference unless something like this happens as the voice in A2DP is going via the phone, but as it is close to you anyway there is impact only on the quality.

deloptes ( 2018-05-30 00:30:58 +0300 )edit
1

answered 2018-09-14 16:22:06 +0300

mp747 gravatar image

In the gui I can only select a typ without the knowledge what profile is used for that type.

For my headset the default profile was in the german translation "Kopfhörer" (This means in english headphone). Changing the language of the device to english shows that this seams to be the type "headset"...dosen't realy match tho the german translation. With this profile, the ringtone was also routet to the heaset as descripted above.

After I saw the comment from deloptes I changed the profile to "Freisprecheinrichtung" (in english hands-free) which seams to be in the english translation "car kit". With this profile the phone rings and the call itself is routed through the headset. This is the solution for me.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
4 followers

Stats

Asked: 2018-05-26 20:24:58 +0300

Seen: 196 times

Last updated: Sep 14