Ask / Submit
11

[bug] Clock alarm routed only over head phones (if plugged in)

Tracked by Jolla (In release)

asked 2018-06-01 16:27:38 +0300

schmittlauch gravatar image

updated 2018-06-03 03:04:40 +0300

Since Sailfish OS 2.2.0.29 the alarm clock sound isn't played via the loudspeaker anymore, but only via the plugged-in headphones. This makes the alarm clock function nearly useless. This happens both in silent and non-silent mode.

How to reproduce:

reproduced on Jolla1

  1. Open Clock app
  2. set an alarm to 1 or 2 minutes in the future
  3. plug headphones in
  4. wait

expected result

alarm sound is played via the loudspeaker (and maybe via the headphones, too)

actual result

alarm sound is played only via the 3.5mm-jack connected headphones

edit retag flag offensive close delete

Comments

Yep, indeed; +1

Edz ( 2018-06-01 17:01:10 +0300 )edit

Works for me (AquaFish converted to Jolla C).

pisarz1958 ( 2018-06-02 19:47:35 +0300 )edit
3

This should be configurable, because both makes sense: One would use the loudspeaker to wake you up (regardless whether headphones are plugged in or not), but headphones only if you want a personal notification like "it's 4 o'clock, you have to leave".

This is a system-wide issue, you may be even want to listen to one audio stream via headphones while the loudspeakers play something different (think of watching a video with multiple audio tracks with different languages)...

takimata ( 2018-06-03 13:25:36 +0300 )edit

My JollaC is also unaffected.

gnuheidix ( 2018-06-03 22:17:32 +0300 )edit

I can't reproduce this on Sailfish X

rozgwi ( 2018-06-06 00:58:25 +0300 )edit

1 Answer

Sort by » oldest newest most voted
4

answered 2018-06-18 16:04:08 +0300

jusa gravatar image

Thanks for the report! Only Jolla1 is affected by the issue.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
2 followers

Stats

Asked: 2018-06-01 16:27:38 +0300

Seen: 237 times

Last updated: Jun 18 '18