[feature request] ipv6 Privacy Extensions should be default

asked 2018-06-08 17:30:37 +0200

Stephan gravatar image

updated 2018-06-12 10:32:31 +0200

Please activate ipv6 Privacy Extension (use_tempaddr) by default to prevent tracking. This is the default behaviour of many other operating systems, e.g. Ubuntu since 12.04 LTS.

Best regards Stephan

Related to: https://together.jolla.com/question/6049/ipv6-cannot-set-use_tempaddr/

update

Yes, the sbj-ipv6.conf seems to be configured correct, but my device (SFOS 2.2.0) does not use an temp address.

edit retag flag offensive close delete

Comments

4

This is set as default already in /etc/sysctl.d/sbj-ipv6.conf as far as I can see (SFOS 2.2.0):

[root@Sailfish sysctl.d]# head sbj-ipv6.conf 
# Enable IPv6 tempaddress and prefer it
net.ipv6.conf.default.use_tempaddr = 2
net.ipv6.conf.all.use_tempaddr = 2

Of course the connman thing from the thread you linked to remains, but there is a config fix for it there as well.

nephros ( 2018-06-08 18:08:34 +0200 )edit
2

Yes the config fix is in the related post. But as @p84 mentioned, the fix does work for the first temporary address only. This topic should higher attention to this problem.

Stephan ( 2018-06-12 10:38:21 +0200 )edit