OpenVpn settings: protocol always tcp

asked 2018-06-08 18:47:23 +0200

utkiek gravatar image

updated 2018-06-27 09:29:27 +0200

zagrimsan gravatar image

In advanced settings for openvpn there is the option "protocol type". This option has 3 points: "Standard", "TCP", "TCP".

Please correct the options in "Standard", "TCP", UDP". Thx.

Update 26.6.18: I think the error is a translation error (in german) (see comment)

edit retag flag offensive close delete

Comments

My openvpn config says "problems with connection" and stay inactiv. In the .ovpn file is the option "proto udp".
[update] now running after changing permissions for client.up / client.down files. I had to start openvpn manual in terminal to see the error messages. In settings under details for my vpn I found "protocol udp" but on the config page the protocoll is shown as "tcp".

utkiek ( 2018-06-08 18:50:47 +0200 )edit

I had to figure out some likely unrelated issues after upgrading both the server and the client after last time I needed my VPN, but in my case I do have UDP available in "Protocol type". Both the server and client configs have "proto udp", and the setup works just fine. I have openvpn-2.4.5-1.3.1 as well as vpnc-0.5.3-1.2.1 installed from jolla repo in case that counts (I'm not sure what the vpnc package even does).

zagrimsan ( 2018-06-26 16:39:27 +0200 )edit

@zagrimsan: You are right. I think the error is a translation error (in german).Look at /usr/share/sailfish-vpn/openvpn/advanced.qml. There is a "ConfigComboBox" id "openVpnProto" with this values: "_default", "udp", "tcp-client"

utkiek ( 2018-06-26 17:08:00 +0200 )edit

I can confirm that by switching the language on my device to German, I could reproduce the issue. So, it is a translation bug.

zagrimsan ( 2018-06-27 09:29:06 +0200 )edit