tethering on Jolla 1 under 2.2.0.29 (Mouhijoki): setting up WiFi fails

asked 2018-06-15 14:55:36 +0200

barral gravatar image

I have installed the tethering app on my Jolla 1, which is updated to vers2.2.0.29 (Mouijoki), and which has the default network setup.

After having configured SSID and PSK within the Tethering Settings, it is still not possible to activate WiFi Tethering, The Enable Wifi Tethering in the drop-down menu is still deactivated, and when I go back to the settings dialog, my previously added configuration is not present, as if saving the configuration via the Save button has not had any effect.

Also tried Enable Bluetooth Tethering, but this ends with "Error: Permission denied"

Does anyone else experience this? And what can be done about it?

edit retag flag offensive close delete

Comments

1

Is your data connection enabled?, if not, you cannot enable tethering unless data is enabled, also, permission denied usually means you need to 'devel-su' first ~ as an example;

devel-su connmanctl tether wifi on (enter) (your-password) (enter) - error; but enables tethering.

devel-su connmanctl tether wifi off (enter) (your-password) (enter) - no error but does disable

Edz ( 2018-06-15 15:37:23 +0200 )edit
1

thanks a lot for the hints!

mobile data connection is enabled, wifi is (currently) not have tried the devel-su commands to turn tether wifi on, it does not issue any error on my phone, but just returns normally. And still the same issu as described in the original post.

cannot try this with wifi data connection on at the moment, but would appears strange to me if a wifi data connection to another hotspot would be necessary. Mobile data connection should be fine, shouldn't it?

barral ( 2018-06-15 16:12:29 +0200 )edit