Ask / Submit
24

Android app DB Navigator refuses login

asked 2018-06-28 15:44:15 +0200

jollajo gravatar image

updated 2018-07-03 08:14:09 +0200

lpr gravatar image

Since last week (maybe since last OS upgrade or upgrade of Navigator app) my installation of DB Navigator refuses to log me in. First it refused to load my tickets, then I reinstalled the app, tried older versions all with the same behaviour. Now with a new app installation I try to enter my user credentials and get the error message "An error orrcured during loading or saving. Please try again, for example by refreshing the tickets in the ticket section of the DB app." Of course I get the warning message "DB Navigator won't run without Google Play services, which are not supported on your device." as in previous versions you can accept by "OK", disable "Show map" in Settings and that message is gone.

I also captured an AlienDalvic log by calling devel-su chroot /opt/alien /system/bin/logcat. That didn't give me a hint on the root of the problem. See: dbnavigator.log

I'd like to confirm if that is just me or does that happen to others as well? My system: Jolla C - SfOS 2.2.0.29, no gapps / googl play services installed, App-Version: 18.06 p03.01

Do you have any other idea where to hunt for the error?

edit 20180703 by @lpr : new version 18.06p03.02 shows same behaviour.

edit retag flag offensive close delete

Comments

1

I just trieb that as well and installed the latest Version of the DB-Navigator App from Yalp-Store. Same problem. the Login is not working. I tried to login on the Website from my computer and there was no problem... as the loginservice as such is working, the problem must be in the App or Alien Dalvik.

Raymaen ( 2018-06-28 16:35:52 +0200 )edit

@Raymaen thanks for your confirmation. What your phone? Do you have gapps / Google Play installed?

jollajo ( 2018-06-28 16:48:15 +0200 )edit

same here on jolla1 sfos2.2.0 aliendalvik 0.17.35

lpr ( 2018-06-28 17:02:27 +0200 )edit

hey, i have Xperia X with latest Sailfish version (2.2.0.29), no Google Play. just Yalpstore to get Aps from google playstore... :-)

Raymaen ( 2018-06-28 17:21:16 +0200 )edit

now I tried DB Navigator 17.12 p03.01 on a LineageOS-Tablet that also doesn't have gapps installed, it works there. Deleted my version on the phone, reinstalled that version with the same error.

So my first conclusion is that's probably related to Sailfish and/or our version on AlienDalvik. However I have no clue wher to search.

The funny thing: several months ago I had a similar issue with that app, somehow it was resolved but I cannot remember what I've done. Very sad.

Is there anyone out there with a working installation?

jollajo ( 2018-06-29 01:32:42 +0200 )edit

2 Answers

Sort by » oldest newest most voted
9

answered 2018-06-29 11:32:40 +0200

jollajo gravatar image

Now I've found an answer, however no solution:

Deutsche Bahn has switchted to TLS1.2 in their encryption to access your account. There's a Website in German: link text

The thread in the German support forum.can.be found here

They say you need Android 4.4 which I thought we have on JollaC and XperiaX. After User reports that's not working with Android 4.4 they claim.you need Android 5 and newer.

Unfortunately I don't have an idea how to verify if out r AlienDalvik supports TLS 1.2.

An alternative is to use trainline.eu.

edit flag offensive delete publish link more

Comments

1

XperiaX user here - loading tickets does not work anymore, I can confirm that... DB Navigator is the most important android app for me :/

jollaticktack ( 2018-06-29 15:24:57 +0200 )edit

+1 - not very happy... and I also would be happy to have tls1.2 on the android apps: because of this I need to leave my own web servers to lower tls

cy8aer ( 2018-06-29 15:52:41 +0200 )edit

same here. xperia x, tickets won't load anymore... but in app purchases still work... just loading the newly bought ticket won't work...

toba ( 2018-06-29 16:32:36 +0200 )edit

Same with me. Its an important app. And as i see no alien dalvik updates for Jolla1 anymore i think i have to move over to another phone very soon. :-( But to be honest i dont expect any big updates for Jollac or Xperia either as Android 5 uses another JVM ( < not too sure about that)?

MrHundert ( 2018-06-29 17:34:03 +0200 )edit

Just an addition: I have the problem with a JollaC too. But there are differences between both phones: Jitsi works on C but not on 1.

cy8aer ( 2018-06-30 13:23:45 +0200 )edit
0

answered 2019-02-02 20:55:31 +0200

Epicuri gravatar image

updated 2019-02-15 23:57:15 +0200

With the new 3.0.1.14 beta release for the Sony Xperia XA2 providing the new android compatiblity layer it is again possible to login into DB Navigator and load your tickets - Amazon appstore version only that doesn't rely on google play services! However, i haven't tried to buy new tickets yet.

I would like to add that on my Xperia X with 3.0.1.11, I still can't login and load tickets anymore in the same version (16.08.06.20) from amazon appstore. So I guess that this new android compatibility layer provides TLS 1.2.

Edit 2019-02-15: Buying and loading new tickets works (of course only via wlan, no internet connection on mobile data, which is a general issue of the 3.0.1.14 beta release).

edit flag offensive delete publish link more

Comments

Interesting, the 'normal' app from google playstore/yalp always complains about no internet connection , no matter whether I use WiFi or mobile data. Where can I download a version without google play services ?

Daniel.T ( 2019-02-02 21:31:20 +0200 )edit

Are you (or is someone else) able to test if the Strava app works on XA2? Both seem to be affected by the same TLS library issue on Xperia X.

ziellos ( 2019-02-02 21:36:47 +0200 )edit

@Daniel.T The simplest way to get the working version would be to visit https://www.amazon.de/androidapp in an android browser, like firefox in the compatibility layer (on other systems there is no download option), and install the amazon appstore. There you can find the DB Navigator (version 16.08.06.20) that does not rely on google play services for login. It is an older version, but I don't know if the versions from google play store or alternatives are identically to that one offered by amazon.

Epicuri ( 2019-02-02 23:31:10 +0200 )edit

Thanks, I was confused because I couldn't download a store with SFOS stock browser...

But now the amazon store keeps crashing. I experienced this already with a lot of apps. I'll have to find out why first, I think.

Daniel.T ( 2019-02-03 03:13:02 +0200 )edit

If you disable Google Maps in your profile's settings the warning disappears.

jollajo ( 2019-02-03 11:19:41 +0200 )edit
Login/Signup to Answer

Question tools

Follow
14 followers

Stats

Asked: 2018-06-28 15:44:15 +0200

Seen: 1,213 times

Last updated: Feb 15