Android SDK Version 21 Required for Android apps

asked 2018-07-04 01:09:15 +0200

jimjamz gravatar image

updated 2018-07-04 16:15:42 +0200

jiit gravatar image

The only related question which I could find that related to "Android SDK updates" was this one (which I also helped to answer): link text

I require a certain Android app that is updated very frequently. I have only been able to obtain this via the Yalp store. When trying to install within the Yalp store app, it is giving me a "parse error". Instead, I tried to directly install this via the File Manager app but this ultimately reports that "Android SDK version 21 is required" and only "Android SDK version 19 is installed".

Is it possible to update the Android SDK to the latest possible version?

edit retag flag offensive close delete

Comments

Please add a tag so we know which device you are using.

Edz ( 2018-07-04 02:07:15 +0200 )edit
1

I've added a tag to display my device but just to clarify, I'm using the Xperia X F5121.

jimjamz ( 2018-07-04 08:15:59 +0200 )edit

My short answer: no.

Long one: I don't think we will ever see an Alien Dalvik upgrade for Xperia X. It was born with 4.4.4 (version 19), and it will die with it, with only minor updates to better integrate SFOS with it. Jolla 1 is still at 4.0, and maybe we will be able to see 5.0 in an upcoming version (SFOS 3?) only on newer devices (XA2? Russian device?).

magullo ( 2018-07-04 10:33:22 +0200 )edit

The way it looks to me, if any devices get Alien Dalvik 5.x or better in SFOS3, the X will be among them. I might be wrong, but here's hoping.

pakman ( 2018-07-04 23:00:52 +0200 )edit
1

The same question was posted a few days before yours: https://together.jolla.com/question/186788/android-apps-are-requiring-lollipop-api-21/

Sthocs ( 2018-07-05 16:17:39 +0200 )edit