Ask / Submit
2

Contact occupy RAM

asked 2018-07-13 13:20:15 +0200

samuel3578 gravatar image

Hi

1.1gb of my Sailfish X Ram keep occupied by the process "contactsd" It lasted for months, and it is quite distrubing as it makes my phone often run out of memory. Anyone know how to deal with this? Thank you!

edit retag flag offensive close delete

Comments

Cool! you must have everybody on this planet as a penpal... have you ever phoned me?

juiceme ( 2018-07-13 15:04:04 +0200 )edit
1

I wish i could have the whole planet contact and speak with you talk for the whole day.

But sadly I don't, I think i only have several hundreds contacts, it is hard to see through the existing UI. I stopped to sync with email accounts long time ago.

samuel3578 ( 2018-07-13 15:51:14 +0200 )edit

Yeah, I kind of thought so. :)

However; you seem to have seriously bloated contactsd since if it really takes up more than a gigabyte of memory... Imagine if you had one million contacts then each of those would take a megabyte of space, you'd have a fairly high-resolution photo of each of your million contacts, along with the usual contact data!

juiceme ( 2018-07-13 17:56:42 +0200 )edit

Umm my contact list used from my Nokia N8, Iphone 4, Blackberry Z30 till now I didn't set photo for contact and duplicate contacts was deleted Shouldn't take that much space 😶

samuel3578 ( 2018-07-13 19:06:54 +0200 )edit
1

I'd export all contacts and check the file through with a text editor for any cruft from so many earlier migrations.

Manatus ( 2018-07-14 12:16:31 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-10-31 19:28:01 +0200

mcencora gravatar image

This is still a problem on 3.0.0.5 version (it eats 1GB-1.5GB of RAM, and one whole CPU core alternately with google-contacts).

Can I help somehow to narrow down the problem?

edit flag offensive delete publish link more

Comments

2

some people have investigated back then. turns out, it's the google contact synchronisation going bonkers and filling the database with dummy "deletion/upgrade" entries.

The quick fix is to shut down contactsd (systemctl --user stop contactsd.service as the normal nemo user), kill the content of contacts database (either rm /home/nemo/.local/share/system/privileged/Contacts/qtcontacts-sqlite/contacts.db* or move them to somewhere else, as the root user)m and restart contactsd (systemctl --user start contactsd.service as the normal nemo user), and wait to resync the database from Google. It's not definitive, eventually it will grow back.

The still sucky, but slightly more permanent fix is to do the same, but first delete your Google account from "Settings" beforehand, and afterward re-add the google account, but only in one way "cloud to device" mode, not in bidirectional sync. Then, it won't grow, but you'll not be able to add contacts to google from within the native sailfish contacts app, only through web.

DrYak ( 2018-10-31 21:23:34 +0200 )edit

I am not quite sure about how to work with those command but then i will try to delete and re-sync

samuel3578 ( 2018-11-01 03:41:09 +0200 )edit

I just removed the google account and reset, no improvement =[

samuel3578 ( 2018-11-01 03:47:27 +0200 )edit
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2018-07-13 13:20:15 +0200

Seen: 320 times

Last updated: Oct 31