Ask / Submit
4

IPSec XAUTH PSK VPN for Fritz!Box

asked 2018-07-15 09:41:45 +0300

ds1979 gravatar image

Dear Sailors,

I am trying to connect my Jolla1 to my Fritz!Box 7490, but something is not going well. I have managed to connect my laptop running Ubuntu Linux 18.04, so I have tweaked around with the settings according to that, but it doesn't work.

Has anybody managed to get this running?

Thanks a lot!

Cheers Dejan

edit retag flag offensive close delete

Comments

3 Answers

Sort by » oldest newest most voted
1

answered 2018-08-15 17:00:49 +0300

gust gravatar image

Jolla deploys vpnc without the "recent" patches needed for VPN with the AVM Fritzbox. The version number is the most recent, but there is a "new"(2014) build of vpnc binary from a maemo thread via previous discussion.

For testing I replaced (after a backup) /usr/sbin/vpnc with the above binary and the VPN-GUI seems to work. The Fritzbox immediately shows the status of the relevant user as "active" in https://fritz.box -> Internet -> Freigaben -> VPN .

edit flag offensive delete publish link more

Comments

1

@gust: could you tell me what you did to make it working? you configured the connection via the sailfish GUI or the "/etc/vpnc/default.conf" file? any test I did returns always a connection error.

AlmAck ( 2018-10-25 23:09:26 +0300 )edit

Can somebody tell me, if the changes in the vpnc package (https://together.jolla.com/question/201103/changelog-302-oulanka/#201103-vpnc) in the 3.0.2 update contain the patches needed or do you still need to load the alternative version from the thread?

dimmu ( 2019-03-20 13:00:59 +0300 )edit
0

answered 2018-07-15 11:19:04 +0300

ghling gravatar image

updated 2018-07-15 12:02:04 +0300

Update: Seems like Jolla added IPSec support via the VPNC package, so you are correct that it should work. For a long time, SFOS only supported OpenVPN, hence my assumptions on the original post. Sorry to miss the update.

So, what are the errors you are getting when the connection fails?

Original post (outdated):

Based on your title and a quick research, I'm pretty sure that the FritzBox VPN bases on IPSec, while the VPN implementation in SFOS is based on OpenVPN. These two protocols are completely different and not inter-operable, so your only possible options are:

  • get IPSec support on your Jolla (most likely with strongswan): As far as I know, there is no easy way for that (no App or GUI), you'd have to compile the package itself and manage everything from the command line
  • switch the VPN on FritzBox to OpenVPN: This seems not possible, since FritzBox does not have OpenVPN support in its Firmware (and most likely will not add it).

So unless you have some knowledge in compiling and shell management and are willing to experiment with it, there's no way in connection your Jolla to a FritzBox. Nevertheless, feel free to contact the Jolla Support (https://jolla.zendesk.com/hc/en-us/requests/new) to confirm my assumptions (and show them, that there is a demand for IPSec support).

One thing you could do of course is running an OpenVPN server behind your FritzBox, if that is an option for you.

edit flag offensive delete publish link more

Comments

Well, when I open up new VPN settings, the third textbox on the first screen is called IPSec identifyer. No you tell me, that SFOS does not support IPSec. How does that fit with your answer?

ds1979 ( 2018-07-15 11:41:53 +0300 )edit

VPN on Jolla is still beta, and OpenVPN is the only option usable. So far.

Nieldk ( 2018-07-15 11:50:11 +0300 )edit

Copy that. :-)

ds1979 ( 2018-07-15 12:01:09 +0300 )edit

@ds1979 : sorry, you are correct. I missed the update where Jolla added IPSec support via VPNC. I've updated my answer.

ghling ( 2018-07-15 12:03:05 +0300 )edit
1

Well, my phone is working on german, so it states: "Problem mit der Verbindung - Automatisch wiederverbinden" which would be in english: "problem with the connection - automatic reconnection"

I don't know how to read the log, so some help would be handy. Perhaps I will find some hints to fix that.

ds1979 ( 2018-07-15 12:13:30 +0300 )edit
0

answered 2018-11-01 01:45:37 +0300

Dietmar gravatar image

By replacing the vpnc binary, I could use the GUI to connect, but the connection did not actually route any packets. Even after adding a route, it did not work. Setting up a /etc/vpnc/default.conf, starting from the cli and then adding a route, did work, though. So the guide at the bottom of https://together.jolla.com/question/157359/2109-vpn-config-for-fritzbox/ is still valid.

(On Sailfish X with today's update to rev. 3.)

edit flag offensive delete publish link more

Comments

For me replacing the vpnc binary worked well. Thanks a lot ! Fritz!Box7560

StPauliFan ( 2019-01-11 20:16:32 +0300 )edit
Login/Signup to Answer

Question tools

Follow
6 followers

Stats

Asked: 2018-07-15 09:41:45 +0300

Seen: 854 times

Last updated: Aug 15 '18