Ask / Submit
4

[bug] Browser opens only 1 external link [released]

asked 2018-07-19 15:04:39 +0200

PatsJolla gravatar image

updated 2018-08-14 22:01:37 +0200

Hi folks, I have a strange problem (since the previous update) with my sailfish browser. Whenever I opened a link in another app (being it android or native app) it only opened the browser and loaded the page if the browser was not opened already. In the past everything worked as expected you click 7 links you end up with 7 tabs.

Now the browser jumps into the foreground but nothing happens.

And since the last update now opening a link from android does nothing - you get the selection window (either android browser like IceCatMobile or sailfish) and when you choose sailfish you just end up in the loop of selecting the browser again. Very strange.

I switched now to webcat as native browser but setting it as the default browser took several tries and sometimes the browser doesnt load mediacontent correctly...the sailfish browser does that even better...if I copy&paste the link manually.

So my question: Is there a setting issue that I can check or should I reinstall the sailfish browser? which is the correct pkcon install command? I don't want to experiment with several commands so if somebody can tell me, would be perfect..

Update: After 1 month of trying to solve it and reinstalling the browser I'm still not any step further.. Still links from android apps don't open at all while sailfish apps can only open the broser with the link if it was not active before..additional tabs don't work

edit retag flag offensive reopen delete

The question has been closed for the following reason "released in a software update" by PatsJolla
close date 2018-10-09 21:28:49.178299

Comments

Have you changed the default using Mimer since updating?

I had a similar issue that was fixed by re-setting defaults using Mimer

rfa ( 2018-07-19 22:47:55 +0200 )edit

This happens to me since update to 2.2.0. Mime didn't change anything. Setting Webcat to the default browser results in the same behaviour: it only opens an URL if the app is closed.

jollajo ( 2018-07-19 23:31:57 +0200 )edit
1

yes to both... but it didn't change something...one time i changed manually the file in an editor and i could stop the android opening loop, but after the last update it came back... I was able to switch to the webcat browser through Mimer but the behavior is like I described it in the OP.

PatsJolla ( 2018-07-20 00:07:33 +0200 )edit
devel-su pkcon install -y sailfish-browser
Edz ( 2018-07-20 05:56:16 +0200 )edit

Thanks that worked...but It didn't solve the problem...

PatsJolla ( 2018-08-14 21:59:36 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-10-09 21:27:39 +0200

PatsJolla gravatar image

I can finally close this question since the last update everything works again normally. I guess the latest update reset something

edit flag offensive delete publish link more

Question tools

Follow
5 followers

Stats

Asked: 2018-07-19 15:04:39 +0200

Seen: 296 times

Last updated: Oct 09