Vibration and sound lost on Xperia X

asked 2018-07-23 21:49:00 +0200

soson gravatar image

updated 2018-07-24 11:08:16 +0200

I lost vibration in pulley menu on my Xperia X and there is no sound at all (ring tones, media player...). i have tried to reboot but the problem preserved. im pretty sure that hardware is working. for example when typing in calculator app or terminal i can feel the haptic feedback.

how can i restart sound service or make some diagnostic, what is causing the problem (some logs...)?

EDIT:

systemctl --user restart pulseaudio.service

Job for pulseaudio.service failed because a timeout was exceeded, See "systemctl status pulseaudio.service" and "journactl -xe"

systemctl status pulseaudio.service

● pulseaudio.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)

journactl -xe

-- Unit UNIT has begun starting up.
Jul 24 09:42:18 Sailfish kernel: clearpad clearpad: (clearpad_process_irq:4152) no work, interrupt=[0x00]
Jul 24 09:42:19 Sailfish kernel: clearpad clearpad: (clearpad_process_irq:4152) no work, interrupt=[0x00]
Jul 24 09:42:24 Sailfish kernel: clearpad clearpad: (clearpad_process_irq:4152) no work, interrupt=[0x00]
Jul 24 09:42:24 Sailfish pulseaudio[21322]: Failed to open audio hw device : Invalid argument (22).
Jul 24 09:42:24 Sailfish pulseaudio[21322]: Failed to load module "module-droid-card" (argument: "rate=48000"): initialization failed.
Jul 24 09:42:24 Sailfish pulseaudio[21322]: Module load failed.
Jul 24 09:42:24 Sailfish pulseaudio[21322]: Failed to initialize daemon.
Jul 24 09:42:24 Sailfish pulseaudio[21322]: PID file '/run/user/100000/pulse/pid' not mine!
Jul 24 09:42:38 Sailfish systemd[991]: pulseaudio.service: Start operation timed out. Terminating.
Jul 24 09:42:38 Sailfish systemd[991]: Failed to start PulseAudio.
-- Subject: Unit UNIT has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit UNIT has failed.
-- 
-- The result is failed.
Jul 24 09:42:38 Sailfish systemd[991]: pulseaudio.service: Unit entered failed state.
Jul 24 09:42:38 Sailfish systemd[991]: pulseaudio.service: Failed with result 'timeout'.
Jul 24 09:42:39 Sailfish systemd[991]: pulseaudio.service: Service hold-off time over, scheduling restart.
Jul 24 09:42:39 Sailfish systemd[991]: pulseaudio.service: Start request repeated too quickly.
Jul 24 09:42:39 Sailfish systemd[991]: pulseaudio.service: Unit entered failed state.
Jul 24 09:42:39 Sailfish systemd[991]: pulseaudio.service: Failed with result 'start-limit'.
Jul 24 09:42:42 Sailfish kernel: clearpad clearpad: (clearpad_process_irq:4152) no work, interrupt=[0x00]
Jul 24 09:42:44 Sailfish kernel: clearpad clearpad: (clearpad_process_irq:4152) no work, interrupt=[0x00]
Jul 24 09:42:52 Sailfish fingerterm[13430]: [D] unknown:0 - unhandled ansi sequence  'h' (1034) "?"
Jul 24 09:42:56 Sailfish pulseaudio[21432]: Failed to open audio hw device : Invalid argument (22).
Jul 24 09:42:56 Sailfish pulseaudio[21432]: Failed to load module "module-droid-card" (argument: "rate=48000"): initialization failed.
Jul 24 09:42:56 Sailfish pulseaudio[21432]: Module load failed.
Jul 24 09:42:56 Sailfish pulseaudio[21432]: Failed to initialize daemon.
Jul 24 09:42:56 Sailfish pulseaudio[21432]: Failed to open PID file '/run/user/100000/pulse/pid': No such file or directory
Jul 24 09:42:56 Sailfish pulseaudio[21432]: Failed to open PID file '/run/user/100000/pulse/pid': No such file or directory
edit retag flag offensive close delete

Comments

1

This command will restart the audio service, but I'm not sure about vibration;

systemctl --user restart pulseaudio.service
Edz ( 2018-07-24 02:34:34 +0200 )edit

thanks for you help, i edited my question based on your suggestion. it seems like pulseaudio has problem with creating pid file.

soson ( 2018-07-24 11:09:19 +0200 )edit

@soson

If I also do systemctl status pulseaudio.service I get the same output that you do, but if I do systemctl --user status pulseaudio.service I get a totally different output;

[nemo@Sailfish ~]$ systemctl --user status pulseaudio.service
● pulseaudio.service - PulseAudio
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
   Active: active (running) since Tue 2018-07-24 06:47:23 CEST; 4h 3min ago
  Process: 1463 ExecStart=/usr/bin/pulseaudio --start $CONFIG (code=exited, status=0/SUCCESS)
  Main PID: 1476 (pulseaudio)
    CGroup: /user.slice/user-100000.slice/user@100000.service/pulseaudio.service
           └─1476 /usr/bin/pulseaudio --start -n --file=/etc/pulse/arm_qct_msm8930_cdp.pa
Edz ( 2018-07-24 11:51:35 +0200 )edit

executing systemctl --user status pulseaudio.service i got this output:

 ● pulseaudio.service - PulseAudio
   Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
   Active: failed (Result: start-limit) since Tue 2018-07-24 10:06:05 CEST; 1h 4min ago
  Process: 25294 ExecStart=/usr/bin/pulseaudio --start $CONFIG (code=killed, signal=TERM)
soson ( 2018-07-24 12:13:56 +0200 )edit

perhaps to reinstall pulseaudio?

Edz ( 2018-07-24 12:44:42 +0200 )edit