Ask / Submit
3

Browser starts again and again with jolla.com

Tracked by Jolla (In release)

asked 2018-08-17 19:52:28 +0300

tscherfel gravatar image

updated 2018-08-22 14:15:57 +0300

jiit gravatar image

On my Xperia X i do nothing, but the browser starts again and again with the page jolla.com. I changed the Homepage to blank, but it still starts again and again with jolla.com. When I start the browser manual it loads a blank page. So something in the Phone want to start the jolla.com page. Have somebody an Idea?

edit retag flag offensive close delete

Comments

This also affects Jolla1. My home page has been google.co.uk for as long as I can remember.

After reading your question, I headed to Settings/Apps/Browser and changed my home page to 'jolla.com'. As expected, when I opened the browser, it opened with 'jolla.com'. I changed back to my usual homepage (google) using exactly the same URL as before, closed and reopened browser and it still loads with 'jolla.com'.

Nice find, most certainly another bug to be added to the regressions list of sailfish-browser.

+1

Edz ( 2018-08-17 21:02:56 +0300 )edit

My X Compact will automatically try to load it on connecting to a public wifi captive portal. I noticed in /usr/share/jolla-settings/pages/browser/browser.qml that there is a line, 'default: jolla.com'.Changing that might work to change the page, but I don't know how to stop it from doing it.

Levone1 ( 2018-08-18 14:33:24 +0300 )edit

@Levone1 - the line of code you found in browser.qml is simply the default page to fall back to if a user does not set a homepage. Oddly enough, editing that line to any other URL, still makes no difference and the browser still loads 'jolla.com', even after editing and rebooting the device, yet my home page is still actually set to 'https://www.google.co.uk/'. I even over installed sailfish-browser and still 'jolla.com' insists on monopolising the browser. So editing, reinstalling make no difference - the plot thickens!

Edz ( 2018-08-18 14:53:35 +0300 )edit

I just deleted that whole section of code, and still the same....

Levone1 ( 2018-08-18 21:22:21 +0300 )edit
1

@Levone1 & @tscherfel

After further fiddling around and then coming back here, I read the answer from @rgrnetalk and he is right. With 'close all tabs on exit' applied in settings, I can set the homepage to open any page I want and it gets opened first time, so it looks like there is no bug after all, just some confusion over what gets opened from where.

Edz ( 2018-08-19 13:26:44 +0300 )edit

6 Answers

Sort by » oldest newest most voted
2

answered 2018-08-20 12:39:03 +0300

Fellfrosch gravatar image

I think the threadopener is misunderstood. The problem isn't, that if HE/SHE STARTS the Browser Jolla.com is the startpage, but that the Browser opens on it's own all the time with Jolla.com.

I also have this problem on one of my Jolla1. Part of the problem here is definitely the SIM Card. Putting in another SIM Card the Browser stays closed.

edit flag offensive delete publish link more

Comments

I get this too, with my Xperia F5122. I haven't found an answer, I just put it down as a minor annoyance that came with the latest update.

pakman ( 2018-08-20 12:56:39 +0300 )edit

Can you check, what happens, when you insert another SIM-Card?

Fellfrosch ( 2018-08-20 16:28:04 +0300 )edit
2

answered 2018-08-22 19:14:23 +0300

tscherfel gravatar image

I think the problem was that the browser constantly opens for auth but in a bit different way. I think it was the provider Vodafone that opens the browser. Because when I try to open any page in the browser Vodafone redirect me to a page from where I can buy more High speed Traffic. My High speed Traffic for the month was empty and the page from Vodafone prevented to open another page with low speed. So thats why I think it was Vodafone. Now I have a new month and new High speed data volume, Vodafone does not redirect to the page and my browser don't opens constantly. So the problem is solved and I know where it comes from.

Thank you all for your answer.

edit flag offensive delete publish link more

Comments

Hello sailors, I have noticed the same behavior. Now that I have the full high speed volume again, the browser does not seem to open on its own. I am from Germany and use Vodafone. Good luck. Continue sailing.

rosapold ( 2018-08-23 00:00:27 +0300 )edit

My question: how does Vodafone do this? Do they send something like a 'Location' header when phone tries to setup a connection to (ipv4.) jolla.com?

addydon ( 2018-08-27 21:04:18 +0300 )edit
1

answered 2019-07-24 14:06:21 +0300

jovirkku gravatar image

updated 2019-07-24 14:10:24 +0300

The reported issue (at least when caused by a captive portal) was eliminated by a fix in OS release 3.0.3.

edit flag offensive delete publish link more
0

answered 2018-08-19 12:53:44 +0300

rgrnetalk gravatar image

updated 2018-08-19 12:55:18 +0300

The browser opens with the tabs you had open the last time you used the browser. When you close all tabs, then close the browser and open it again, the browser will open with the home page set in settings\ apps\ browser or if it's blank with the remark "search or enter address"

edit flag offensive delete publish link more

Comments

If I activate "close all tabs" in the settings of the Browser it opens always with my homepage (clean page in my case)

dirksche ( 2018-08-19 13:15:56 +0300 )edit
0

answered 2018-08-22 14:14:33 +0300

jiit gravatar image

updated 2018-08-22 14:17:51 +0300

According to our developer this is an existing "captive portal bug" and being worked on. You can read more from these posts:

https://together.jolla.com/question/159823/dont-use-default-browser-profile-for-captive-portals/

https://together.jolla.com/question/79000/bug-browser-constantly-opens-for-auth/

edit flag offensive delete publish link more
0

answered 2018-09-23 13:30:27 +0300

rosapold gravatar image

Hello Sailors, the bug still exists in the version SFOS 2.2.1.18 (Nurmonjoki). But I can live with it. Next time I will try to solve the problem as described here:

https://together.jolla.com/question/79000/bug-browser-constantly-opens-for-auth/

I will report then. Have fun until then and sail on.

edit flag offensive delete publish link more
Login/Signup to Answer

Question tools

Follow
3 followers

Stats

Asked: 2018-08-17 19:52:28 +0300

Seen: 531 times

Last updated: Jul 24