phone record named "unknown" and call history missing when phone number is not saved as a contact

Tracked by Jolla

asked 2018-09-10 11:57:24 +0200

baptx gravatar image

updated 2019-11-01 22:33:20 +0200

After having recorded several calls from phone numbers that were not saved as a contact (by pressing the record button of the phone app), go to "settings" -> "apps" -> "phone" -> "recorded calls" and you will see that all recorded calls are named "unknown" followed by the date / time of record.

This is not convenient if we want to find a past record and we have a lot of records. If the record was made with a phone number that is not saved as a contact, it should be named according to the phone number and date / time of record (unless someone really called us with an unknown number by hiding it, the record could be named "unknown" with the date / time of record).

Update: there is another issue related, the call / SMS / MMS history named "activity" is missing when a phone number is not saved as a contact. I updated the title to include this information.

edit retag flag offensive close delete

Comments

1

Thank you for the report; we have this in our database.

jiit ( 2018-09-12 11:52:42 +0200 )edit

Just need names with phone numbers, not unkonwn
image description

sashikknox ( 2019-11-01 15:49:48 +0200 )edit

@sashikknox if you record a call to a phone number not saved as a contact, it will be displayed as "unknown" when you go to "settings" -> "apps" -> "phone" -> "recorded calls". I tested with the latest release 3.1.0.11 and the problem is still here. It looks like you don't have the problem on your screenshot, which firmware version are you using? Or did you do something special to make it work?

baptx ( 2019-11-01 22:30:58 +0200 )edit

@baptx, i know this, sorry for my comment if its confuse you, i just rename files with call records in file manager, to show how it should look, without "unknown" ...

sashikknox ( 2019-11-02 22:37:42 +0200 )edit